Numerous sudden problems with 2006 MBP

Discussion in 'MacBook Pro' started by donnaf, Jan 26, 2010.

  1. donnaf macrumors newbie

    Joined:
    Apr 3, 2009
    Location:
    St. Louis, MO
    #1
    I have MBP Tiger 10.4.11 intel powerbook, purchased in '06 when they were initally released, & the logic board was replaced twice under Apple Care warranty. Past problems have been a nightmare to say the least. Has been doing OK tho' with some minor glitches since warranty expired.

    This week, it has begun randomly doing all sorts of strange things without command such as the following: drawing squares in the middle of a page, highlighting within any application, highlighting names of files, dragging names of files at random, dragging applications out of dock, dragging names of files without command, dragging items out of sidebar. (I have the box checked to ignore accidental input from the trackpad; under trackpad, only clicking & dragging are checked), I've zapped the pram to restore defaults and repaired permissions. Tried to run the Tech Tools CD, but it made an odd noise when I held the C key down upon restart and the disk didn't work.

    Also, when a .jpg image or any other type of image is moved out of a file to the desktop, the actual picture is shown rather than the icon that's in the file.

    In my Pages application, Fonts is only showing one font rather than all the collections. It's not giving me options for managing fonts. I can reinstall IWorks, but thought that would be rather useless until I get things straightened out.

    I've never had all of these problems until this week, and the reason is totally escaping me. No spills, drops, or destructive actions. Any ideas anyone? HELP!!

    Thanks,
    Donna Fantozzi
     
  2. gonewestcoast macrumors member

    Joined:
    Jun 16, 2009
    #2
    At four years in, you're approaching the end of the machine's expected life.

    That being said, does the problem still occur when you use external peripherals? If it's a trackpad / keyboard issue, an external set might help isolate this.

    Define "disk didn't work" as well, please.
     
  3. donnaf thread starter macrumors newbie

    Joined:
    Apr 3, 2009
    Location:
    St. Louis, MO
    #3
    Thx for responding so quickly. The Tech Tool disk didn't work - when I clicked on applications, there was no response. Apple had sent me this CD after I received the computer, stating that it was an update. I recall trying to use it once before, & it didn't work then either.

    I went into System Preferences and deselected 'dragging'. That seems to be helping a lot. I'm confused though, because I recall having that checked before.

    I have a Maxtor hard drive and was backing up everything. YES, I did have all of the same problems when using this.

    Any thoughts? Again, thx for your thoughts.

    Donna
     
  4. Inside_line macrumors regular

    Joined:
    Jun 21, 2005
    Location:
    U.S.A.
    #4
    I have a 2006 that act strange sometimes but not like that... mine will come out of sleep when plugging in the power cord, and sometimes restart when I choose shutdown.

    Anyway, have you tried using an external mouse? Set it to ignore trackpad when external mouse is used and see if your cursor issues go away. It doesn't sound like iwork is related to that, other than maybe your fonts got deleted by the chaos.
     
  5. cluthz macrumors 68040

    cluthz

    Joined:
    Jun 15, 2004
    Location:
    Norway
  6. donnaf thread starter macrumors newbie

    Joined:
    Apr 3, 2009
    Location:
    St. Louis, MO
    #6
    Apple Hardware Test

    No I haven't. Is that when you insert the install disk 1 that came with the program and check for errors?

    Thx again for your suggestions. I think I know how to do this. Will look it up.
     
  7. moel macrumors 6502

    Joined:
    Nov 7, 2007
    #7
    Donna

    sounds strange...might i suggest backing up and then nuking and paving the system.
     

Share This Page