Resolved NVIDIA 304.79 Drivers Failing Install on rMBP in Windows 8

geoffreak

macrumors 68020
Original poster
Feb 8, 2008
2,193
2
I cannot seem to get the NVIDIA 304.79 drivers to install under Windows 8 on my rMBP. During installation, the core graphics driver is just listed as "Failed" and the installation stops.

I am using the English (US) version of the driver and I have modified the INF file correctly. I have tried to perform a clean installation of NVIDIA drivers (under custom installation). I have tried completely removing the existing NVIDIA drivers.

Anyone else encountered this issue?
 
Last edited:

JacaByte

macrumors 6502
Dec 26, 2009
315
0
Are you sure you're not trying to install nvidia's drivers over any default graphics drivers other than Window's default frame-buffers? You might want to check and make sure that you're currently using the defaults in the Hardware and Devices control panel.

Edit: Doing a quick search for drivers on nVidia's site reveals that there are no stable drivers for the Geforce GT 650M for Windows 7/8 yet; it appears that 304.79 is a beta driver for now. You might want to consider waiting for stable drivers.
 

MacReloaded

macrumors 6502
Oct 31, 2007
407
0
Canada
I figured it out after some experimentation. This is specific to Windows 8 and is not required in Windows 7:

  1. Open up the Charms bar.
  2. Click on Settings.
  3. Click on Change PC settings.
  4. Click on General.
  5. Under Advanced startup, click Restart now.
  6. When the blue screen shows up, click on Troubleshoot.
  7. Click on Advanced options.
  8. Click on Startup Settings.
  9. Click on Restart.
  10. Your system now reboots and when the blue screen shows up, press F7 on your keyboard.
  11. Windows boots up and then you can install the drivers with the modified INF.
 

crimsontwo

macrumors member
Jul 23, 2008
32
0
I figured it out after some experimentation. This is specific to Windows 8 and is not required in Windows 7:

  1. Open up the Charms bar.
  2. Click on Settings.
  3. Click on Change PC settings.
  4. Click on General.
  5. Under Advanced startup, click Restart now.
  6. When the blue screen shows up, click on Troubleshoot.
  7. Click on Advanced options.
  8. Click on Startup Settings.
  9. Click on Restart.
  10. Your system now reboots and when the blue screen shows up, press F7 on your keyboard.
  11. Windows boots up and then you can install the drivers with the modified INF.
WOW! After literally hours of banging my head against the wall I find this your post and... it WORKS. I'm not on a Mac but it doesn't matter. Apparently this startup mode disables automatic denial of unverified drivers. Wicked. Thanks.
 

jenzjen

macrumors 68000
Aug 20, 2010
1,734
6
I figured it out after some experimentation. This is specific to Windows 8 and is not required in Windows 7:

  1. Open up the Charms bar.
  2. Click on Settings.
  3. Click on Change PC settings.
  4. Click on General.
  5. Under Advanced startup, click Restart now.
  6. When the blue screen shows up, click on Troubleshoot.
  7. Click on Advanced options.
  8. Click on Startup Settings.
  9. Click on Restart.
  10. Your system now reboots and when the blue screen shows up, press F7 on your keyboard.
  11. Windows boots up and then you can install the drivers with the modified INF.
Do you know how to get it to install under Windows 7?
 

somebody32

macrumors newbie
Oct 29, 2012
1
0
If somehow anyone here cannot install nvidia drivers in the new Windows 8 full release:
1. Run the exe for the driver for the first time, and remember the location it extracted to.
2. Go to Control Panel, then Device Manager.
3. Right click your display adapter, and to update driver software.
4. Click Browse my comp, and then click Let me pick device drivers.
5. Click Have Disk, then browse to the location from step 1.
6. Go to Display.Driver under \NVIDIA\DisplayDriver\versionnum\Win8_WinVista_Win7_64\English\, then select nv_disp.inf.
7. It should now install the new driver, and your driver version should now be updated.
Cheers. --Psi
 

awj

macrumors newbie
Nov 1, 2012
7
0
Finally!

MacReloaded, a huge thanks to you sir.

I've spent the past evening and this morning trying many different methods without success. And then I found your post.

One thing I would add to anyone else who has trouble even while trying MacReloaded's solution: at first this failed for me but I then uninstalled the current NVidia driver, rebooted (Device Manager shows that it uses something like "Microsoft Compatibility Driver") and then went through MacReloaded's instructions again.

Furthermore, after I had installed the drivers using those steps, I rebooted and NVidia told me an update was available. This time it installed the drivers by itself.
 

jlambert1

macrumors newbie
Jan 27, 2013
1
0
Windows 8 Problems

Im having a real problem as i just updated my sony vaio vgn ar750e/b to windows 8 and now have no access to my nvidia geforce 8600m gt. im new when it comes to having to modify an .inf and have tried both macreloaded's and somebody32's methods, but without having a modified driver i have yet to instal anything. Thanks in advance.