o2 Mobile Broadband and Snow Leopard

Discussion in 'macOS' started by sparkyms, Aug 30, 2009.

  1. sparkyms macrumors 65816

    Joined:
    Feb 22, 2007
    Location:
    Southampton UK
    #1
    If anyone, like me, experienced complete disaster after updating to Snow Leopard and their Mobile Broadband stopped working... I have a solution..

    Firstly, unplug the dongle from the computer...

    uninstall everything to do with the drivers you currently have:
    /Applications/mobileconnect
    /System/Library/Extensions/HuaweiDataCardDriver.kext
    /Library/Modem Scripts/HUAWEI Mobile Connect - 3G Modem

    Reboot your Mac.

    Then go here:

    http://blog.evandavey.com/2008/02/how-to-connect-huawei-e220-usb-modem.html and download and install the drivers...

    Plug in the dongle and open up Network Preferences.
    Hit the + and select HUAWEI MOBILE..
    and enter the following info in the fields:
    Configuration: Default
    Tel Number: *99#
    Account: o2bb
    pass: password

    hit apply and connect and all should be fixed!
     
  2. otis123 macrumors 6502a

    Joined:
    May 4, 2006
    #2
    my AT&T 3G modem is working fine with SL, but i can't get WWAN status to show up in the menu bar, i check the box, and it unchecks its self!:mad: would this fix that?
     
  3. sparkyms thread starter macrumors 65816

    Joined:
    Feb 22, 2007
    Location:
    Southampton UK
    #3
    I've got absolutely no idea.

    What network card/dongle are you using (i.e. manufacturer).. this fix will only work on Huawei cards/dongles.
     
  4. otis123 macrumors 6502a

    Joined:
    May 4, 2006
    #4
    its a sierra wireless usb mercury, so your fix won't work. Its really irritating that i could get it to work in 10.5 but not SL, i dont know how many bars i have!
     
  5. jeme macrumors regular

    Joined:
    Jun 12, 2009
    #5
    can't get my Mercury connect USB to work at all in Snow Leopard. Unbelievable...
     
  6. NATO macrumors 68000

    NATO

    Joined:
    Feb 14, 2005
    Location:
    Northern Ireland
    #6
    I was about to throw my O2 dongle out the window because I just couldn't get OS X to display the HUAWEI network interface until I realised I had my MacBook Pro set to boot with the 64-bit kernel. As soon as I switched back to the 32-bit kernel it worked immediately - the kext for the dongle obviously isn't 64-bit :rolleyes:

    So thanks to the OP for the helpful instructions and a piece of info for anyone else running the 64-bit kernel wondering why their mobile broadband dongle isn't working!
     
  7. Rubyjones macrumors newbie

    Joined:
    Sep 28, 2009
    #8
    Could you tell me if this works if you have not already been using the broadband mobile. I have installed snow leopard and did not know this problem existed, since then i have bought an o2 dongle and cannot get it to work.
     
  8. Shuggyx macrumors newbie

    Joined:
    Nov 26, 2009
    #9
    Thanks SparkyMS, that sorted me out brilliantly. My issue was slightly different in that I had bought a new MacBook Pro running 10.6 after my old MacBook (10.4) was stolen. I found that the O2-supplied Huawei connection application wouldn't run at all. I didn't have to delete any files as they weren't there on my new machine, but the new drivers worked absolutely fine first time.

    Thanks again - brilliant!
     

Share This Page