O2 Problems lately?

Discussion in 'iPhone' started by 226896, Aug 13, 2009.

  1. 226896 Guest

    Joined:
    Sep 13, 2008
    #1
    The past two nights, I've experienced a stupid problem with my service. Basically, people will text me, but I won't receive them. They will 'queue', and they'll all flood to my phone at once when I send a text and make a call. It's like theres a gate that texts queue up outside of, and when I make a call or send a text myself, the gate is opened up to let the texts in, then it closes again (yea that's the best way to describe it). This is SO ANNOYING and people think I'm just not replying to them. My girlfriend also said she couldn't even call me because it went straight to voicemail.

    Texting is my main method of communication, so this problem is really starting to tick me off. I've done resets, and even restored the phone to no effect. Has anyone else been experiencing the same issue? If it's just me then I'll be ringing O2 tomorrow and they better have a good reason as to why this is happening.
     
  2. nazuk macrumors 6502

    nazuk

    Joined:
    Dec 5, 2007
    Location:
    England, UK
    #2
    I Have an iPhone 3G, and obviously being in the UK, i'm on O2 as well.

    I too have not received texts one day, as far as I am aware, this week.

    Again, my friend thought I was ignoring them, and kept sending me more texts, but none got through. That's the only problem I am having.

    My phone is not jailbroken or hacked in anyway.

    I just put it down to a network issue with O2, but whether it's fully resolved or not is unclear.
     
  3. pauliphone macrumors regular

    Joined:
    Nov 27, 2008
    Location:
    London, UK
    #3
    o2 are pi$$ing me off big time, this past month has been a complete nightmare, either texts not being sent/received, data services down, calls going straight to voicemail etc....
    i sent them an email moaning etc, they have given me £10 credit off my next bill, not much considering all the problems.
     
  4. Supersonic macrumors regular

    Joined:
    May 24, 2006
    #4
    I had this with O2 too a few weekends back, it was hell. my texts were going to some people and replies back, but to some people like my missus, it just didnt happen at all. She thought I was ignoring her. Oddly enough, through a 2nd person, we made contact but not direct.

    Then it cleared up, and all was fine, but a raft of a dozen messages just ploughed through, some three days old!!!!
     
  5. JadedBen macrumors regular

    Joined:
    Aug 14, 2009
    Location:
    Essex, UK
    #5
    Hi, long time lurker, first time poster!

    I've been having similar issues too atm with O2, was going to sign up the other day to ask funnily enough.

    It's mainly been with MMS, all has been fine sending/ receiving up untill Tuesday, my friend was round with here baby, took a photo with her phone then sent it to me & my mum straight away, mine took about 5 hours to come through, mum never got hers (though she's on Tesco, but they go through O2 right?).

    My dad tried sending a few testers, but again, didn't get them till about 3 hours later, yet bizarrely the ones i sent him & my mate both went straight through? (me & dad both have 3G's. my mate some samsung)

    txt's seem ok, but i swear my friend has sent a couple that i havn't got, & visa versa?



    Funnily enough i didn't have a problem before i upgraded to 3.0.1, could the bug fix has created a new bug? I assume you guys are all on the same?
     
  6. ct2k7 macrumors 603

    ct2k7

    Joined:
    Aug 29, 2008
    Location:
    London or Florida
    #6
    Hello,

    Interestingly, this is the first that I've heard of the issue. Can you locate yourselves to a common area? Have you rebooted the phone in the past 24 hours?
     
  7. 226896 thread starter Guest

    Joined:
    Sep 13, 2008
    #7
    I'm in Bristol. I'm texting people right now and it's been happening all day. Think I'm gonna ring O2.
     
  8. ct2k7 macrumors 603

    ct2k7

    Joined:
    Aug 29, 2008
    Location:
    London or Florida
    #8
    Yes, give CS a call, and say that you'd like to lodge a network fault.
     
  9. Willis macrumors 68020

    Willis

    Joined:
    Apr 23, 2006
    Location:
    What feels like the middle of nowhere
    #9
    I've had flakey service for the last two weeks. I've installed the carrier update (4.4) and data services seem fine, but I constantly get 'Voicemail unavailable'

    As for receiving calls, someone who was picking my PowerMac up last night tried calling 3 times before he got through. Grrr

    I'm in Lincolnshire
     
  10. TomxHow macrumors member

    Joined:
    Aug 11, 2009
    #10
    In SE England and I've been experiencing similar problems with O2, not with an iPhone, but still... :)
     
  11. JadedBen macrumors regular

    Joined:
    Aug 14, 2009
    Location:
    Essex, UK
    #11
    I'm in Essex, but it seems to be ok now, sent & received fine since i last posted?

    I guess O2 were having issues or enough people phoned to complain and sorted it?

    Everyone else's ok now?
     
  12. 226896 thread starter Guest

    Joined:
    Sep 13, 2008
    #12
    I hate to bump an old thread but is anyone having these problems again recently? It's doing my nut in.
     
  13. drlunanerd macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #13
    The BBC are collating problems with O2's 3G network at the moment.
     
  14. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #14
    Yup...sometimes i have to resend txts twice or thrice before it goes through and sometimes i only get blank txts or delayed txtx, I also recently dropped a call and my area is blanketed (NW) with coverage from all carriers
     

Share This Page