O2 Public WiFi Stopped Connecting, iPhone 5 connects fine

Discussion in 'Mac Basics and Help' started by gregular, Mar 3, 2015.

  1. gregular, Mar 3, 2015
    Last edited: Mar 13, 2015

    gregular macrumors newbie

    Joined:
    Mar 3, 2015
    #1
    I am a bit green, so please bear with me.

    I've got a MacBook Pro Retina - Late 2013, running OS X Yosemite 10.10.2

    For the last 3 months I have been going to a popular coffee shop chain in London, UK (Costa Coffee). O2, in partnership with Costa, provides access to public WiFi for free. It has been working no problem up until a few days ago.

    Now, at the coffee shop, my iPhone 5 still connects fine, but the MacBook has stopped. That is, MacBook connects to WiFi, but lists "No Internet Connection" with the exclamation point on the WiFi symbol.

    MacBook still connects to home WiFi no problem.

    I have tried a number of things:
    - Restart
    - Shut Down, Reboot
    - Clear Internet Cache
    - Remove all other "remembered" WiFi's I've used on the Macbook
    - Disconnected Bluetooth
    - "Using DHCP" - Tried "Renew DHCP Lease"
    - DNS blank
    - DNS using Google (8.8.8.8)
    - Ensure proxies are all off
    -Deleted entire Library/Preferences/SystemConfiguration folder, with reboot
    - Tried the Kext Utility thing seen on Reddit sub post
    - Actually, tried all of the options on that sub
    -->UPDATE
    - tried removing laptop from O2 list of devices
    - format and reinstall of OS X Yosemite. Clean wipe. No luck
    - Am now trying to learn/figure out how to change MAC address (spoof)

    Anybody have any other ideas?

    Thanks!

    Greg
     
  2. satcomer, Mar 4, 2015
    Last edited: Mar 5, 2015

    satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Did you try to open System Preferences->Network pane, Advanced button and deleted the previous connections and try the connection again?

    Another more drastic fix is going back into System Preferences->Network pane and use the - button to delete your Airport card, then log out. Then log back in and back into the Network pane use the + button to re-add your Airport card and save (Apply button).
     
  3. gregular thread starter macrumors newbie

    Joined:
    Mar 3, 2015
    #3
    Hey, it's worth a try! Thanks for the suggestion. I'll hit the coffee shop tomorrow and see if that works.

    And I'll also bring a book. Just in case :)
     
  4. ckubi macrumors newbie

    Joined:
    Mar 5, 2015
    #4
    I've had this exact same problem with the same laptop specs as you. Phoned apple support which couldn't help. I've only tired it in the Coast near Southwark tube station.
     
  5. gregular thread starter macrumors newbie

    Joined:
    Mar 3, 2015
    #5
    Tried both, and neither worked.

    It is very weird. It is obviously my MacBook, but I also see lots of hotspots in the cafe, perhaps meaning others are having the same problem?

    Any other thoughts?
     
  6. phosphors macrumors newbie

    Joined:
    Mar 12, 2015
    #6
    I'm having the very same problem. No trouble joining multiple other wifi services, home and Uni and other public hotspots. But Costa/O2 wifi + Macbook Air = Exclamation indicator with no wifi access. Meanwhile, my iPhone connects to the Costa/O2 service immediately.

    I've found two fixes which I've had to use several times in the last few weeks. The first is rather easy. Log onto wifi.o2.co.uk management portal and remove the laptop if listed. This generally will allow the laptop to re-register to the O2 wifi system. However, that didn't work for me just this morning. So I had to do resort to the second more difficult method, changing the MAC address of the wireless adapter.

    It definitely seems like an issue between O2 wifi service and Macbooks, as my iPhone has zero trouble.
     
  7. gregular thread starter macrumors newbie

    Joined:
    Mar 3, 2015
    #7
    Maybe there is something with Macbook Pro and this network then. I have tried removing laptop from the list of devices, no luck with that.

    Now I'm trying to figure out the MAC spoof on OS X Yosemite, but am basically learning how to use terminal, and learning how to do this spoof. Would love advice if you've got some.

    My Costa that doesn't work is near Turnpike Lane station in N7. Maybe it is all of them though, haven't tried another yet.

    Thanks for posting
     

Share This Page