O2 UK 3G problem connecting calls?

Discussion in 'iPhone' started by Hudzilla, Sep 28, 2008.

  1. Hudzilla macrumors 6502a

    Hudzilla

    Joined:
    Nov 12, 2007
    Location:
    England
    #1
    Is anyone else having issues when switching 3G on?

    My calls dont connect, and safari is hit and miss.

    But if i toggle it off, everything works perfectly???
     
  2. 226896 Guest

    Joined:
    Sep 13, 2008
    #2
    I've been having weird problems since 2.1. Sometimes calls take about 60 seconds to connect, and sometimes text messages won't send unless I reset the phone. God knows what's going on.
     
  3. Satori macrumors 6502a

    Satori

    Joined:
    Jun 22, 2006
    Location:
    London
    #3
    No problems for my 3G connection. I'm based in North London and 3G coverage seems pretty good most places I go. If I switch between 3G and 2G sometimes I get a delay in finding a full strength signal.
     
  4. Hudzilla thread starter macrumors 6502a

    Hudzilla

    Joined:
    Nov 12, 2007
    Location:
    England
    #4
    Seems abit hit and miss then,:confused:, i might give O2 a call in the morning and see if they know something we dont :rolleyes:
     
  5. mack120 macrumors newbie

    Joined:
    Mar 13, 2008
    Location:
    Cheshire
    #5
    pprobs also...

    Prior to the update just had the usual lagging on the keyboard, text tone always very low, etc. never had a dropped call.
    Since the update i noticed a marked improvement in the battery life to begin with but it seems back to normal now????
    And as for dropped calls. I was blaming other people for have crap phones , when mine was the common denominator??
    Applications seem to crash more and on the internet its slowed right down. Blue bar on the address bar gets to 1 cm then delays before opening the page. Appears to lag.
    GPS find me doesn't work indoors, were it did prior to update.
    I live in cheshire and coverage seems to dip greatly of a night but O2 tell me it is fine. But can vary from no service to 3 bars in a matter of feet????

    love to hear others comments

    Mack
     
  6. ibizarocks macrumors regular

    Joined:
    Oct 2, 2007
    #6
    search for my thread on 'O2 network problems?'. I've been having some issues as well. With 3g off the phone is sweet, with it on it's useless. I can be standing in the same spot and watch my signal go from 5 bar 3g to edge and then down to standard 2g 1 bar then work it's way back up to edge, stop there for a bit then back up to 4 bar 3g then 5. It's so pathetic how a phone marketed as a 3g phone is completely useless in 3g mode.

    oh, and whilst it's doing this I've worked out when the phone switches from 2 to 3g you can't receive calls.
     
  7. Hudzilla thread starter macrumors 6502a

    Hudzilla

    Joined:
    Nov 12, 2007
    Location:
    England
    #7
    Just rung O2, got the usual "try a restore", "switch the phone off and on".

    After about half an hour of explaining, they agreed to send me a replacement SIM out to try.


    Cant help to try
     
  8. David2070 macrumors member

    Joined:
    May 14, 2008
    Location:
    UK
    #8
    I get exactly the same problems. Since 2.1, if I have 3G on I cannot receive or make calls. If I turn 3G off, the phone works perfectly.

    I know other people that are having the same problem so I doubt it is the sim card.

    Let us know how the new card works out though...
     
  9. monkeytennis macrumors member

    Joined:
    Jul 7, 2008
    #9
    I also get this occasionally. A call I was trying to make to a friend on Sunday took about 30 seconds to connect. The 3G signal said full but Safari etc. wouldn't work until I reset the phone completely.
     
  10. ibizarocks macrumors regular

    Joined:
    Oct 2, 2007
    #10
    well i think the problem is something that should be at the forefront of Apple / o2 to get sorted!! I'm actually telling everyone who asks not to bother with the iphone because it simply isn't up to the job it claims to be able to do.
     

Share This Page