Obj-C/cocoa, my first app problem

Discussion in 'iOS Programming' started by ksiedzulek, Apr 19, 2011.

  1. ksiedzulek macrumors newbie

    Jan 6, 2011

    This is my first application for Iphone.It's a calculator, there is no error in code I suppose. Application is launching but buttons doesn't work. please exam this project. I really need answer:/ project in attachment.

    Attached Files:

  2. chown33, Apr 19, 2011
    Last edited: Apr 19, 2011

    chown33 macrumors 604

    Aug 9, 2009
    on the Western Slopes, with E. A. Poe
    Explain exactly what "doesn't work" means.
    1. Describe what you expected to happen.
    2. Describe what actually happens.

    What have you tried for debugging your code?
    Have you tried adding NSLog() statements to your IBAction targets?
    Have you tried setting breakpoints using the debugger?

    Why would you suppose there are no errors in your code?
    I took a quick look and found several errors, some of them serious mistakes in memory management. There are also some failures to assign objects to ivars.
  3. ehoui macrumors regular

    Jan 27, 2011
    You have to do at least 95% of the work before you ask for help. You need to isolate the problem and then post for help if you can't figure it out. If you can't / won't isolate it, you are not going to get much help. The beauty of this system is that your odds of figuring it out on your own after isolating it go way, way, way up. Cheers.
  4. Blakeasd macrumors 6502a

    Dec 29, 2009
    In your processDigit method you set currentNumber to currentNumber * 10 + digit . I don't see where you set currentNumber's value.
    By The Way, this sould be in the IOS programming section, you might get more help there... ;)

Share This Page