Objective/File is busy

Discussion in 'macOS' started by PhiLLoW, Feb 11, 2016.

  1. PhiLLoW, Feb 11, 2016
    Last edited: Feb 11, 2016

    PhiLLoW macrumors 6502

    Joined:
    May 31, 2014
    #1
    Hi Macrumors,



    i need your help. Last night I moved some pictures from a SD-Card to an USB drive. The file transfer was successful and the „move“ window closed like always. Later when I tried to edit the files I noticed that they were transparent and I can’t do anything with them. Open with preview( space ) works fine and they are displayed correctly. Double click ( open ) doesn't work. Also no copying, no moving, no deleting, no opening in photoshop etc.

    The file size is of the folder is as big as I expected so the files have been moved correctly. The files on the sd-card have been deleted by Finder after moving was successful )



    I googled the problem but unfortunately I only found people who had problems with deleting their bin/trash.



    Can anybody help me? The pictures are very important.



    I already tried to plug/unplug the usb drive. Also connected it to another Mac. The files were still transparent.

    edit:
    Tried some Finder Alternatives.

    File is busy ( - 47 ) error
     

    Attached Files:

  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    Try right-clicking on one of the pictures and select GetInfo. Then in the GetInfo box, scroll down to Sharing and Permissions and see what the permissions are for the file. If they are not Read & Write for the particular user you are logged in as, change them to Read & Write.
     
  3. PhiLLoW thread starter macrumors 6502

    Joined:
    May 31, 2014
    #3
    Hey JohnDS,

    thank you for your reply. I already tried that and got the permission to read and write but couldn't do anything.

    I figured out a workaround. I booted Windows 7 in parallels and copied the files to another place. This somehow broke the "file is busy"-status.

    Funny that even a second Mac couldn't edit the files after switching the usb drive.
     

Share This Page