Obnoxious Problem after updating to 10.7.3- dedicated card always being used?

Discussion in 'Mac OS X Lion (10.7)' started by GuitarG20, Feb 9, 2012.

  1. GuitarG20 macrumors 65816


    Jun 3, 2011
    Hi all,

    MBP 8,3 Early 2011 17" with the 2.2 GHz i7.

    I just recently updated to 10.7.3 with software update.

    Ignoring the fact that I had to repair both my disk and permissions after updating (yeah...) I've noticed that now, the screen flashes blue during start-up (something that used to only happen when I was connecting a monitor.

    This made me curious, so I checked iStat pro after booting, and it appeared that for some reason the computer had used my GPU during boot up (it was at operating temps instead of the ones it hangs at when it's not being used.) So no big deal, right? I looked at "about this mac" and gfxCardStatus and both say I am on the integrated.

    But, this doesn't explain why i am only getting an estimated 3 hour charge from my battery (with only chrome open) and the fact that my GPU is staying heated up, and my CPU keeps getting warmer and warmer, despite me not doing anything. Also, coconutbattery lists me at 30.2 watts at idle, which is 2-2.5 times what I would normally use at idle.

    I think my MBP is constantly running the dedicated card... is there any way to check this for sure? Is there anything I can do to alleviate this? I can't get through a whole day of classes with only 3 hours of battery life...

    EDIT: And before anyone says that this is normal, and to check my activity monitor, I am still at 3% CPU most of the time, and it's not normal. not for my machine.
  2. squeakr macrumors 68000


    Apr 22, 2010
    Did you check the setting under display to see if the automated switching was engaged? It may be engaging before gfxCardStatus loads during startup, hence the flash once gfxCardStatus starts and switched back??
  3. GuitarG20 thread starter macrumors 65816


    Jun 3, 2011
    my computer never flashes blue when it switches cards though. which some do, I think. I think I might have fixed it, just messed around with gfx for a while.

Share This Page