Observation On Weather/Temperature Display

Discussion in 'Apple Watch' started by papbot, Jul 23, 2015.

  1. papbot macrumors 6502

    Joined:
    May 19, 2015
    #1
    At home this morning I noticed that the temperature reading that I have set on my watch time face had disappeared ( again ). Normally when I see this I just restart my phone and that has always resolved this. But this time I wanted to try a few other things.

    I went to the native weather app on the phone and saw all the weather info for the cities I have included as well as the one for my current location which is supposed to be the one the watch uses for that time face display. However I realized that the temp display for my location was incorrect, it was now much warmer than it was showing. Playing around with this some more I deleted one city from the list and attempted to add another one. But each time I entered a zip code or city name it just showed "no results" for the search.

    So checking into this further I tried accessing a web site in Safari and could not make a connection. I was on my wifi network so thought maybe there was an issue with my isp or my own network. But checking on my laptop I was able to get on line with no issue. So going back to my phone I cut wifi off, going on to the cell network. I waited for a couple minutes and went back to the weather app on the phone and now my location as well as the other listed cities all updated to current temperatures and adding another city now worked. So apparently there was a problem with the phone's utilization of wifi which also had affected the watch.

    Leaving wifi off on the phone I went back to the watch and saw that the temp reading had now reappeared. I went back to the phone and turned wifi back on and everything was now working again. This happens often enough that I believe it's an iOS 8 bug that continues in 8.4 and subsequently affects functions on the watch. And I'm still convinced that most of the issues that arise on the watch are due to some similar glitch on the phone which a restart of the phone or turning off wifi temporarily may resolve.
     
  2. JohnApples macrumors 65816

    Joined:
    Mar 7, 2014
    #2
    I've actually had this happen to me too occasionally, with and without the watch. Sometimes my iPhone 6 will be unable to do the simplest of tasks, like updating the weather or fetching my e-mail, on my Wi-Fi. All my other devices seem to be working perfectly fine on Wi-Fi, but as soon as I switch to LTE on my iPhone, it loads the data without a hitch.

    Pretty annoying, especially when Apple Support gives me the same run around. Resetting my network settings for the 5th time won't solve it. I'm sure.
     
  3. papbot thread starter macrumors 6502

    Joined:
    May 19, 2015
    #3
    Yeah, that won't work except temporarily and it affects every other device you have logged into that iCloud account. Again, normally I would have restarted the phone but I wanted to avoid it this time so I tried turning the wifi off and then back on in a few minutes. When my weather temp display came back on the watch I did notice it was the wrong temp. I checked the watch app on the phone and for some reason the default city had changed to one of the other ones on my list. Once I set it to my location again all was good.
     

Share This Page