OC Z Vertex 4 SSD in Quad Core i7 MBP?

Discussion in 'MacBook Pro' started by camelian, Apr 18, 2012.

  1. camelian macrumors newbie

    Joined:
    Apr 18, 2012
    #1
    Hi all,

    Has anyone successfully installed a new OC Z Vertex 4 SSD in a quad core i7 MacBook Pro? Specifically, I have an early 2011 2.2 GHz 15" MBP.

    I just got the Vertex 4 in and it recognizes/runs lion fine in a 13" C2D MacBook Pro but once I stick it in my 15" quad core, it doesn't even recognize the drive. I tried booting off a Lion install disk to run Disk Utility and it doesn't see the drive at all. I also had a Samsung 830 on hand to test and that runs fine.
     
  2. camelian thread starter macrumors newbie

    Joined:
    Apr 18, 2012
    #2
    Update:

    I've tried using the Vertex 4 512GB drive in the following computers with mixed results:

    YES 13" MacBook Pro 5,5 2.53GHz Core 2 Duo
    NO 15" MacBook Pro 8,2 2.2GHz Quad Core i7
    NO 15" MacBook Pro 6,2 2.4GHz Dual Core i5
    YES 15" MacBook Pro 5,4 2.53GHz Core 2 Duo

    Whenever it doesn't boot up in a system, the system doesn't even recognize it as a drive, whether mounted internally or connected externally through USB enclosure. All systems are fully up to date with firmware updates already done.
     
  3. chilly7 macrumors member

    Joined:
    Mar 22, 2012
    #3
    Did u contacted OSZ about this issue u are having?:)
    What did they say you?

    p.s. i am looking to buy the same SSD but for a new MacBook Pro and i want to be shure it will work well with it....
     
  4. /user/me macrumors 6502

    Joined:
    Feb 28, 2011
    #4
    Based on the fact that it's not working with core i processors, it sounds very much like a firmware issue. A simple update should fix it :)
     
  5. camelian thread starter macrumors newbie

    Joined:
    Apr 18, 2012
    #5
    I've submitted a ticket, I'll keep you posted on what they say
    In the mean time, the price has gone down more than $100 with a sale on NewEgg...
     
  6. camelian thread starter macrumors newbie

    Joined:
    Apr 18, 2012
    #6
    Interesting..giving OC Z the same diagnosis that I posted here, the tech replied saying that it's a DOA and to setup replacement with NewEgg.

    Is there a way it would be partially DOA such that it works fine on C2D but not on Core i processors?
     
  7. macuserx86 macrumors 6502a

    macuserx86

    Joined:
    Jun 12, 2006
    #7
    Could be some of the drives shipped with the wrong firmware (rather, earlier firmware) and they're going to quietly remedy it.

    I'm probably going to grab a 128GB one of these to replace the aging Vertex 2 in my MacBook Pro. The Mac Pro's lack of SATA 6 means it's left behind, plus the 128GB Vertex 2 is still fast enough. I wish there was a good 2.5" thunderbolt enclosure for my old 60GB Vertex 2 though; the thunderbolt enclosure options are... depressing.
     
  8. bozz2006 macrumors 68030

    bozz2006

    Joined:
    Aug 24, 2007
    Location:
    Minnesota
    #8
    I would say that in this case, DOA is a pretty broad term. SSDs tend to be a little finicky, and this one in particular is acting very finicky. So, they want you to gt a different one. I suppose they figure it's not worth anyone's time to try to fix this one.
     

Share This Page