Occasional flashing lines??

Discussion in 'MacBook Pro' started by AndyR, May 29, 2011.

  1. AndyR macrumors 6502a

    AndyR

    Joined:
    Dec 9, 2005
    Location:
    Auckland, New Zealand
    #1
    Hey all,

    My late 2008 MBP has been working great ever since I had it, but in the last few weeks its been running a bit sluggish. I originally decided to do a fresh install as hadn't done it for a good few years and this seemed to help, then last week I started having really slow boot up issue (5 mins) after booting into bootcamp and back to Mac OSX.

    Now the last 2 nights while using my Mac (either OSX or Bootcamp) I'll occasionally get a horizontal line flash across the screen. Only there for half a second or so and then gone, seems to be random, not affected by the angle of the screen so dont think its a hinge/cable problem.

    Any ideas what it might be?

    Thanks.
     
  2. AppleNewton macrumors 68000

    AppleNewton

    Joined:
    Apr 3, 2007
    Location:
    1 Finite Place
    #2
    sounds like a graphics card issue. maybe display.
    have you tried opening the case of the machine and cleaning out any dust that might clogged up inside and in the fans?
     
  3. AndyR thread starter macrumors 6502a

    AndyR

    Joined:
    Dec 9, 2005
    Location:
    Auckland, New Zealand
    #3
    Not yet no, might give that a try tonight then. Thx.

    Was worried it might be graphics, as have noticed one of the sims I play in bootcamp, used to always get rock solid 84fps, but since the problems it'll fluctuate between 60-80fps now too.
     
  4. AndyR thread starter macrumors 6502a

    AndyR

    Joined:
    Dec 9, 2005
    Location:
    Auckland, New Zealand
    #4
    Just to finish this off.

    Turned out to be a faulty display. It gradually got worse and ended up with a solid yellow vertical bar in the center of the screen, took it in for repair under applecare and they replaced the entire display.

    All good now, apart from they gave me the wrong screen so it no longer sleeps as the sleep magnet is in the wrong place! Oops, so going back again.

    Andy
     
  5. AppleNewton macrumors 68000

    AppleNewton

    Joined:
    Apr 3, 2007
    Location:
    1 Finite Place
    #5
    ouch, at an Apple store or authorized provider?
     
  6. AndyR thread starter macrumors 6502a

    AndyR

    Joined:
    Dec 9, 2005
    Location:
    Auckland, New Zealand
    #6
    Authorized provider as there are no Apple stores in NZ :(

    Thought it was my Lion install which caused it as once I got it back from repair I upgraded straight away. Only noticed it didn't go to sleep when I took it out it sleeve the next morning and it was boiling hot!!! :mad:

    Going to take it back this week now, realized it was the screen when someone suggested placing a magnet on the display bezel and then matching on the side of the case to see if it sleeps. If I put a magnet just on the edge of the case near the optical drive, bham it goes to sleep, but if I close the lid, nothing.
     

Share This Page