Occasional "invalid sim" and "no service" error messages

maokh

macrumors 6502
Original poster
Jun 9, 2007
260
18
Seattle, WA
At least once a day, for the past 3 days, my iPhone has been suddently displaying "no service" within a pretty well covered area. It does not find signal again. In order to aide it in a search, i flip on and off airplane mode. This triggers a sim error popup message and "invalid sim" shows up at the top left of the screen.

I need to reboot the phone in order to gain cellular service again.

Has anyone had this problem before?
 

MattyMac

macrumors 68000
Oct 6, 2005
1,691
7
NJ/NYC
At least once a day, for the past 3 days, my iPhone has been suddently displaying "no service" within a pretty well covered area. It does not find signal again. In order to aide it in a search, i flip on and off airplane mode. This triggers a sim error popup message and "invalid sim" shows up at the top left of the screen.

I need to reboot the phone in order to gain cellular service again.

Has anyone had this problem before?
Unfortunately for your sake (not mine) I have to say this hasn't happened to me. If it continues to happen up to your 14 day return period...I would take it back and see if they can give you another one since it doesn't seem normal and this is the first I've heard of this problem.
 

sdm1130

macrumors newbie
Jul 12, 2007
11
0
At least once a day, for the past 3 days, my iPhone has been suddently displaying "no service" within a pretty well covered area. It does not find signal again. In order to aide it in a search, i flip on and off airplane mode. This triggers a sim error popup message and "invalid sim" shows up at the top left of the screen.

I need to reboot the phone in order to gain cellular service again.

Has anyone had this problem before?

I had this same issue for the first few days after I got my iPhone. Turns out, my data plan was all messed up (I had gone from a Blackberry with AT&T to an iPhone). A few calls to AT&T and a day later things were up and running. I have not had any problems for the week+ since then.
 

cah87

macrumors regular
Jul 7, 2007
170
0
dude i had they same problem just go to att have them replace the sim card and it fixes it. They do this for free also!
:D:apple:
 

jojojoven

macrumors newbie
Jul 9, 2008
1
0
dude i had they same problem just go to att have them replace the sim card and it fixes it. They do this for free also!
:D:apple:
Hi, I had they same problem and also I replace the sim card, but now is the 3rd time and still happen, if some one know a solution please let me know, thanks.
 

EdLee

macrumors member
Apr 5, 2008
46
0
Hi, I had they same problem and also I replace the sim card, but now is the 3rd time and still happen, if some one know a solution please let me know, thanks.
Do you use a case with magnets in it? This happened to me and I had to have my iPhone replaced a few times before I stopped using the case.

Just a thought.

Ed