Odd Data Problem...

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mcmanus7, Jun 1, 2009.

  1. mcmanus7 macrumors 6502a

    Joined:
    Oct 30, 2008
    #1
    Alright here's the deal.. starting a week ago today.. my phone has not been able to readily connect to 3G... at first I thought it was the network.. but i've figured out it's not.. ie.. my sister who also has a iPhone 3G has no problems in the same areas I do..

    It doesn't seem to affect calls.. my calls are still crystal clear and text messaging also does not appear to be affected.. any app that uses 3G data however will not work 100%...

    When it starts to act up.... I can usually get it back by going into settings and clicking on the carrier and waiting for the search to be complete.... then my 3G will work again until I put my phone to sleep...

    Any suggestions?? Fido has been 0 help....

    I would like to add that the full time 3G is always displayed and connecting through wifi works 100%

    Just thought I would also add that i've done both soft reboots and full restores....
     
  2. AgentOrange macrumors newbie

    Joined:
    Dec 23, 2004
    #2
    Something may have broken with your 3G antenna. I've personally experienced issues like that with the Wifi with a refurb I got a few months ago. Brought it in and they replaced it.

    See: http://forums.wireless.att.com/cng/board/message?board.id=apple&message.id=70225

    See also, problems 7 & 8: http://cultofmac.com/how-to-get-the-most-from-your-iphones-warranty/11368/3

    If restoring your iphone's software doesn't fix it, then there's a good chance there's a hardware issue and you should get it replaced under warranty.
     
  3. mcmanus7 thread starter macrumors 6502a

    Joined:
    Oct 30, 2008
    #3
    must have been a network issue... ever since friday i havn't had a issue again... yet my network won't admit there was a problem haha
     

Share This Page