Odd external HD issue on iMac

Discussion in 'iMac' started by musicgeekmusic, Jul 15, 2015.

  1. musicgeekmusic macrumors newbie

    musicgeekmusic

    Joined:
    Jul 15, 2015
    Location:
    Chattanooga, TN
    #1
    OK, not an oh-god-please-help-me-situation, but I would like to figure something out. Got a Western Digital 1TB USB powered external hard drive hooked up to my iMac (Lion 10.7.5, 2.66 GHz Intel Core 2 Duo, 4 GB RAM). Store all my uncompressed iTunes music on it. Worked great. A week or so ago it started vanishing from my desktop and I got the “You didn’t eject this device correctly” message. Managed to back up all 366 GB of music on it, so no problems there, but now my iMac can’t even see the WD external, yet my wife’s brand-new Mac Mini (don’t have specs but it’s brand-ass new) sees it fine, no vanishing acts, either. Swapped USB cords on the WD, no difference on her machine or mine (which still can’t see it). I also have a spare 500 GB WD USB powered external, hooked it up to my iMac and no problems. Sees it fine. My USB ports seem to be OK, I can hook other peripherals to them and there’s no issues. So why can my wife’s Mac Mini see the 1TB, but mine can’t? I totally erased the 1 TB after I backed it up, reformatted it with my iMac and did the same thing to the 500GB, but the 1 TB still doesn’t show on my desktop. One odd thing, for a while, if I fixed Disc Permissions on my iMac's internal hard drive, the 1TB would show up instantly once that was done (got a lot of iTunes corrections), but it doesn’t do that anymore. Like I said, everything is backed up so no data loss, but this is stumping me. If I can save the 1TB and hook it back up to my iMac, that's my preference.
     
  2. R2D2WD macrumors newbie

    R2D2WD

    Joined:
    Sep 23, 2014
    #2
    Hi musicgeekmusic,

    It seems that your external is working properly. The issue may be driver related and you may need to reinstall the external's driver or search for some update from the WD web page. Have you searched for the drive in Finder, Disk Utility or System Profile?
    Please have a look at the KB article below for some suggestions:

    http://products.wdc.com/support/kb.ashx?id=8cfwyP - WD external hard drive is not powering on or is not recognized on a Mac system

    Hope this helps
     

Share This Page