Odd Flash Drive Behavior

Discussion in 'Mac Accessories' started by Adros, Mar 22, 2012.

  1. Adros macrumors member

    Joined:
    Apr 3, 2009
    #1
    I recently inserted a 16GB flash drive into my Mac Pro and got a message that, "The disk you inserted was not readable by this computer". Odd I thought, so I tried unplugging it and plugging it back in a few times, tried my Macbook Pro (same message) and eventually though oh what the hell, just go ahead and reformat it.

    So I opened up disk utility, selected the flash drive on the left (USB DISK 30X Media), clicked on Erase and went to click on Format only to find it was grayed out...

    Anyone run into this before? Never had a flash drive go bad on me before but I suppose anything is possible.
     
  2. leonel.brodhead macrumors newbie

    Joined:
    May 6, 2012
    #2
    I've tried Data Rescue 3

    My wife has a 2GB she has being using for awhile. Today this popped up when she plugged in her thumb drive. "The disk you inserted was not readable by this computer"

    I tried using the Data Rescue 3. No luck!
     

Share This Page