Odd iPod Touch Issue...

Discussion in 'iOS 5 and earlier' started by Spencer Reynen, Nov 20, 2011.

  1. Spencer Reynen macrumors member

    Joined:
    Apr 3, 2011
    #1
    OK, so I just discovered that there was no iPod touch troubleshooting part of the forum, and since this is a software issue anyways, I guess this is the place to post it.

    My brother's iTouch (running 4.2.1) has an odd issue. When trying to launch the Netflix app, it says there is "a problem connecting to Netflix. Please try again later. (1007)" I checked the wifi on it, and it is connected and I can completely browse the internet on Safari and everything. So, thinking it was an outdated version of Netflix, I went to the App Store to update the app. Clicked on updates and updated the app. It then went back to the home screen where it was about to load and I got the following message: "Cannot connect to the store- A secure connection could not be established. Please check your Date & Time settings." WHAT? Why would I check the date and time settings. But I did and got nothing there that could help.

    Trying to solve the issue simply, I rebooted the iPod holding down the home button and power button. It turned on again, NO luck. Tried forgetting my home wifi network and re-inputting all the info back in. NOTHING. My last thing I am going to do is install iOS 5, which I am doing as I'm typing this. Do you think it will solve this issue? If not, what will and what was with the Date and Time message? Help is greatly appreciated and sorry for the long text on what to most of you is a simple fix. Thanks in advance. :)
     
  2. adcx64 macrumors 65816

    adcx64

    Joined:
    Nov 17, 2008
    Location:
    Philadelphia
    #2
    Time and Date is crucial to the App store for some reason. This has happened to me before. Time and Date is crucial for updating software on a PC or Mac, it has something to do with the server. Updating to iOS 5 may fix the problem, but if not, change the time an date to the correct setting after the update.
     
  3. Spencer Reynen thread starter macrumors member

    Joined:
    Apr 3, 2011
    #3
    Updating the iOS to 5 worked, everything runs smoothly and all problems were solved. thanks
     

Share This Page