odd networking problem

Discussion in 'macOS' started by ryanwarsaw, Jan 30, 2008.

  1. ryanwarsaw macrumors 68000

    ryanwarsaw

    Joined:
    Apr 7, 2007
    #1
    Here is the deal... I have a couple of macbooks and an iMac on my home network, they are all C2D machines. One of the MB is on Leopard and one is on Tiger, the iMac is on Leopard.

    I can connect both notebooks and screen share and file share to each other but not the iMac. However I can connect to both notebooks via the iMac. When I try to connect to the iMac after a few minutes of hanging it just says connection failed.

    I never get prompted for a password and the iMac has had some issues with it's keychain not remembering passwords in the past. Is it possible that the issue is the keychain? I was thinking that because the iMac can connect to any machine in my house but nothing can connect to it. So maybe it is something to do with that? After a few minutes of hanging it just says connection failed.

    I could also just be stupid (that is what I am actually hoping so this can be solved).

    Thanks for any help.
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    I assume it's correctly set by default, but to make sure is the correct port open on the iMac's firewall? If not, it could cause what you're seeing--it can talk to other machines, but incoming connections to that port aren't being allowed. Turning its firewall off temporarily would be a quick check.

    Could also be a keychain error, although I would expect you to get a password rejection message rather than just a failure on timeout like that. You could try completely deleting and resetting the keychain to start fresh (though that might be a pain if you have a lot of stuff in it).

    Oh, one other thing: Are these all connected the same way (either wired or wireless), or is the iMac different from the others? If so, it could be that your router(s) are interfering with traffic in one direction.
     
  3. ryanwarsaw thread starter macrumors 68000

    ryanwarsaw

    Joined:
    Apr 7, 2007
    #3
    The iMac is on wifi and one of the notebooks is also on wifi and one is using ethernet. I am pretty sure this is not what is causing the difference. Although if i were really that sure I wouldn't be asking at all. LOL

    I tried to plug one machine directly into the iMac with firewire just to see and it reacted the same way. The firewall is off and always has been so that doesn't seem to be the problem either. I think that the network is strong but am starting to suspect that I am not even getting to the point where i can authenticate or something like that if that makes sense.

    An active firewall would have made sense but that isn't the case unfortunately. I will look even into my router settings but I have run out of ideas to what the solution is. I would really like this to work as it is my way to access my desktop and 1 TB external. If it were the opposite and my iMac didn't connect to my notebooks I would not even care.
     

Share This Page