Odd OS 3.0 issues

Discussion in 'iPhone Tips, Help and Troubleshooting' started by moelelio, Jun 18, 2009.

  1. moelelio macrumors newbie

    Joined:
    Jan 17, 2008
    #1
    Hey everyone,

    Apologies if this has already been voiced; if so please point me in the direction of that thread!

    I upgraded to OS 3.0 along with the rest of the world last night, and am experiencing two highly frustrating issues:

    1) I sync my contacts, calendar, and email with the exchange server at work. When the upgrade was complete, my email, contacts and calendar were all empty, and any attempts to refresh them said 'could not get mail' etc. I tried syncing with iTunes a couple of times, but to no avail. Text Messages, Call history etc just showed numbers. Not very helpful. I tried all sorts, even removing and re-adding the exchange account, but still couldn't get any data down. Then I turned off WiFi, and suddenly it would sync with everything. When I turned WiFi on, it attempted to sync again, failed, then removed all the emails, contacts, and calendars again. I tried it a couple of times and can repeat the behaviour. If I want to connect with exchange, I have to use 3G. The moment I turn on WiFi for anything it drops all of my data. Mighty frustrating.

    2) There are four apps in my app store that have updates. When I select 'update' I get several 'updated terms and conditions' popups, and get taken to the page to agree to the new T&Cs. This happens repeatedly (not just four times) until the only thing left to do is press cancel. The apps never update. So to check that it wasn't a hiccup in the T&C process I 'bought' a free app in the appstore. Sure enough, I was prompted yet again, so accepted etc. The app downloaded and installed fine. I tried getting another app, and this time wasn't prompted. Peachy. However, the update still takes me in this infinite loop of T&C acceptance. I've even tried updating one app at a time, but it still doesn't work. In the end I deleted the app from my phone and downloaded the new one again, which did the trick, though obviously I don't want to have to do this every time there's an update!

    I've tried rebooting, syncing, everything to fix the above issues.

    So basically, I want to know if anyone else is experiencing these issues, if anyone has any suggestions of how to fix them, and if not, does anyone know how I can escalate this to Apple before I drive myself insane?

    Thanks guys!

    Dave
     
  2. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #2
    1. Your IT Dept might need to make a change to their servers to allow the new 3.0 clients to function properly, but I would inquire with them.
    2. Have you tried to download the apps from your desktop/laptop instead? I would try that, see if you can agree to the terms and try and re-sync. Hopefully upon sync it will update your apps. :)
     

Share This Page