Odd problem with sharing folders & screen sharing

Discussion in 'macOS' started by AubreyL, Jan 27, 2008.

  1. AubreyL macrumors newbie

    Joined:
    Jul 10, 2007
    #1
    I have Mac OS 10.5 Leopard installed on 4 computers in a Home Network and have a problem with sharing files and using screen sharing. Here is my setup.

    MacBook Pro with my logon ID
    MacBook Pro with my fiancee's logon ID
    Mac Mini with both of our logon ID's
    mac pro with both of our logon ID's

    The problem I have is I am able to access the Mac Mini computer where we have an external Hard Drive connected for data. He is also able to access it. The only problem is we have it set up to only share this external USB drive. Yet for both of us it shares the external drive along with the internal Macintosh HD. Why is it doing this?

    Also, I am able to connect from the Mac Mini for example to my MBP and vice versa for screen sharing along with file sharing. Yet if he tries to connect to the Mac Pro from his MBP and vice versa it won't. It simply times out and will never connect for screen sharing or file sharing but yet the Finder shows the Mac Pro. We have a 2nd hard drive in the Mac Pro which is the one set up for file sharing. I am also unable to connect to the Mac Pro's HD. Everything appears to be set up correctly.

    We both have .mac but since we are using this on an internal network (some wi-fi, some wired, all through an Airport Base Station Extreme) I would think this has nothing to do with Back to my Mac.
     
  2. stomer macrumors 6502a

    Joined:
    Apr 2, 2007
    Location:
    Leeds, UK
    #2
    By default, when authenticating as an administrator all mounted volumes will be shared. I didn't like this 'feature' either. I had a share called 'shared' and a volume called 'Shared', so the Windows machines were never sure which share they were actually connecting to.

    Anyway, there is a way to fix the problem. You'll need to edit the smb.conf file. Open up terminal.app:
    Code:
    sudo vi /etc/smb.conf
    I use vi to edit files, use whichever editor suits you.

    Just after the line where is says:
    Code:
    include = /var/run/smb.conf
    Add the following:
    Code:
    [homes]
        com.apple:show admin all volumes = no
    
    Then in the Sharing preferences screen, un-tick then tick the SMB sharing option to restart samba.

    Have you checked that there are no IP address conflicts? Try opening Finder, press CMD-K, enter vnc://machinename or vnc://ip-address-of-machine. See if that works.
     

Share This Page