Oddities with RAM and G5 + Leopard Install

Discussion in 'PowerPC Macs' started by iRabbit, Mar 26, 2009.

  1. iRabbit macrumors 6502

    Jul 10, 2007
    I'll try to keep this as short and easy to follow as possible.

    I bought new RAM (4 1-gig dimms, installed in slots 1 and 2) and a new DVD drive and put it in a G5 1.8 x 2. Booted it up and it all seemed to be working fine.

    Then I decided to upgrade to Leopard (Family pack).
    During install the upgrade kept failing. First attempt it told me the DVD was bad (but I know it wasn't - just did an install on a laptop). Next few attempts I kept getting a black screen saying "you must restart your computer" - and it would happen at different points.

    I tried erasing drive and doing a clean install. Still no good.

    Thought it might be the DVD drive. Put the old drive in. Tried again. No good. Same result.

    I probably tried 6 or 7 times before and after swapping the DVD drive.

    So I figured it must be the RAM. Took new RAM out. Put old RAM back in machine (6 256-meg dimms installed in slots 1, 2 and 4). Install went flawlessly.

    Got the machine booted into Leopard. Seemed to be working fine.

    Shut it down. Took old RAM out and put new RAM back in, but this time in slots 1 and 3. Booted it up. Seemed to be working fine. System Profiler shows it installed and working (reports as "ok"). Downloaded a utility called MemTest and ran it. It reports no failures in the memory.

    So what's the deal? Am I going to have problems when I really start using the machine? I have a time-sensitive project I need to do this weekend and don't have enough time to return the RAM and get new. How concerned should I be?

    Any insight would be helpful... thanks!

  2. diotav macrumors 6502a

    Aug 9, 2005
    You shouldn't be concerned at all .. this is a known problem or bug.

    The solution in my case was restoring a Leopard.dmg file on a external firewire harddrive. Installation went flawlessly. :)
  3. iRabbit thread starter macrumors 6502

    Jul 10, 2007
    Thanks for the reply... but what is the known bug? That Leopard doesn't like 1-gig ram dimms in a G5 or ???? I mean, obviously when I put the old ram back in the install went fine, so it was my new ram causing the conflict/problem/bug... just wondering what that specifically is?

    Glad you were able to resolve your problem :)
  4. Earl Urly macrumors regular

    Jul 11, 2004
    Where did you get the RAM? Was it from a Mac-friendly vendor or just some guys saying "OK THIS WILL WORK ON A MAC, NE MAC. KAYTHANXBI"

    I have an old single 1.6 with all 4GB, all PC3200, all from the same exact batch, all Micron Tech and I never had a problem installing Leopard.
  5. iRabbit thread starter macrumors 6502

    Jul 10, 2007
    Got it from MacSales.com (OWC - Other World Computing).

    BTW, been installing software on the machine all night, and so far, no problems.

Share This Page