Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

JWest

macrumors 6502
Original poster
Oct 1, 2007
361
0
Is it possible to adjust the cursor blink rate in Word 2008? It blinks very slowly, and it's kind of annoying. It also doesn't blink at all if I try to use the space bar to move a head a bit, which makes it difficult to know where the cursor will stop. Is there any way to adjust this?
 

absurdio

macrumors 6502
Aug 25, 2003
380
0
RI, Chi, and/or NY.
In what may be a related complaint, I find that the cursor in Word 2008 sometimes vanishes entirely. This could, I suppose, just be an incredibly long pause between blinks. I'm not sure, since the cursor doesn't seem to come back until I restart Word. It's quite an annoyance, though.
 
Comment

Tannerozzy

macrumors regular
Feb 2, 2008
104
1
Waco, Texas
did anyone ever find a fix for this?

:(


I'm using word for the first time tonight and it's driving me crazy not knowing where the cursor is!
 
Comment

spitfire3687

macrumors newbie
Apr 17, 2009
1
0
one of the little things microsoft did to make it more frustrating for mac users. It's probably adjustable in the windows ver.
 
Comment

kl0wne

macrumors newbie
Nov 26, 2008
2
0
Windows has a universal setting to control the cursor blink rate (or stop it all together) and has done as long as I've known it (since about 1996), so I guess it doesn't occur to the Microsoft developers that this would need to be done within the application.

I don't know why Macs don't have an option to stop the cursor from blinking in any application. I really can't think when I see it, it's a bit like someone elbowing me every second.
 
Comment

Goride

macrumors newbie
Jun 15, 2010
26
0
I've lost my cursor, and cannot figure out how to get it back.

I've even quitting and restarting word. It is gone. (note: the cursor is in this text box)

Sometimes, if I start clicking around in different spots, I can get it to blink once quickly, then it disappears again and doesn't come back.


EDIT:

It came back after a full restart of the computer. Still, it shouldn't have happene, imo. =/
 
Comment

tixen

macrumors newbie
Jul 28, 2011
2
2
San Jose, CA
I found a solution to this issue on the OfficeMac forums, but the post (or entire forum?!) had been removed some time ago. Luckily, Google had a cached version of the page from which I was able to extract the instructions provided by user "fafa." The updated summary of these instructions is as follows:

1. Make a backup of ~/Library/Preferences/com.microsoft.Word.plist
(Command + Shift + G from finder, paste in "~/Library/Preferences/" and click "Go", find com.microsoft.Word.plist and make a copy of it somewhere you can find it)

2. Open Terminal and paste the following:
Code:
defaults write ~/Library/Preferences/com.microsoft.Word.plist NSTextInsertionPointBlinkPeriod -int 500

The number at the end is the speed of your cursor in milliseconds; 500ms is the speed the cursor blinks in all of Apple's normal applications. I tested this myself and found it to work in Word 2011, even though the original guide was from Word 2008.

3. Restart Microsoft Word.
That's it!

The text from fafa's original post is quoted below, for posterity.
Actually there is a way, which involves adding an extra parameter to Word's preference file com.microsoft.Word.plist.

First, make a backup copy of that file, as in option-dragging it to the Desktop. You'll find it in your Library > Preferences. And quit Word.

Second, we need to use the Terminal application, in Applications > Utilities > Terminal. Double click it and you'll see an old-style dumb terminal interface with a prompt (this means you'll be moving around using the cursor keys, although you can use the mouse to select, copy and paste). The prompt you'll see will look something like this:

123-456-789-000:~ YourUserName$

Type the following *in a single line* and hit RETURN:

defaults write /Users/YourUserName/Library/Preferences/com.microsoft.Word NSTextInsertionPointBlinkPeriod -int 500

Be strict as to upper and lower case letters, except that instead of YourUserName, you'll type your actual user name (duh, but I had to say it).

The only value you'll need to change is "500," which is the number of milliseconds between cursor blinks. "500" is more or less the equivalent to what you see now (500 ms on, 500 ms off). For a faster blink rate, use a lower number (like 200, to get 5 blinks per second) and vice versa.

After you hit return in Terminal, open Word and check the blink rate (don't quit Terminal until you are satisfied). If you don't like what you see, quit Word and re-issue the command with another number.

Of course, there is a limit for practical values--with a "1" won't set to see 1000 blinks per second.

If you have any problem, quit Word and can restore the file you copied to the Desktop.
 
Comment

maryp

macrumors newbie
May 4, 2010
2
0
Switzerland
the blinking cursor in Word 2011

I tried this but, very strangely, there is no file on my computer called com.microsoft.Word.plist ! I have the new MacBook Air and I just loaded Microsoft for Mac 2011 last week. In library / preferences there were some general microsoft office plist files but not a a Word one. I have multiple users set up on my computer, so I also lookied in my user library preferencepanes, but there are no plist files there.
Any ideas on where else the file could be?



I found a solution to this issue on the OfficeMac forums, but the post (or entire forum?!) had been removed some time ago. Luckily, Google had a cached version of the page from which I was able to extract the instructions provided by user "fafa." The updated summary of these instructions is as follows:

1. Make a backup of ~/Library/Preferences/com.microsoft.Word.plist
(Command + Shift + G from finder, paste in "~/Library/Preferences/" and click "Go", find com.microsoft.Word.plist and make a copy of it somewhere you can find it)

2. Open Terminal and paste the following:
Code:
defaults write ~/Library/Preferences/com.microsoft.Word.plist NSTextInsertionPointBlinkPeriod -int 500

The number at the end is the speed of your cursor in milliseconds; 500ms is the speed the cursor blinks in all of Apple's normal applications. I tested this myself and found it to work in Word 2011, even though the original guide was from Word 2008.

3. Restart Microsoft Word.
That's it!

The text from fafa's original post is quoted below, for posterity.
 
Comment

tixen

macrumors newbie
Jul 28, 2011
2
2
San Jose, CA
I have the new MacBook Air and I just loaded Microsoft for Mac 2011 last week.

Have you opened, altered and saved preferences in Word? I wonder if this file only appears after you change something from defaults?

All I can tell you is it's there for me; I can't imagine it wouldn't be there after you save a configuration of some kind.
 
Comment

dakwar

macrumors 6502
Nov 2, 2010
320
13
I found a solution to this issue on the OfficeMac forums, but the post (or entire forum?!) had been removed some time ago. Luckily, Google had a cached version of the page from which I was able to extract the instructions provided by user "fafa." The updated summary of these instructions is as follows:

1. Make a backup of ~/Library/Preferences/com.microsoft.Word.plist
(Command + Shift + G from finder, paste in "~/Library/Preferences/" and click "Go", find com.microsoft.Word.plist and make a copy of it somewhere you can find it)

2. Open Terminal and paste the following:
Code:
defaults write ~/Library/Preferences/com.microsoft.Word.plist NSTextInsertionPointBlinkPeriod -int 500

The number at the end is the speed of your cursor in milliseconds; 500ms is the speed the cursor blinks in all of Apple's normal applications. I tested this myself and found it to work in Word 2011, even though the original guide was from Word 2008.

3. Restart Microsoft Word.
That's it!

The text from fafa's original post is quoted below, for posterity.



Thanks, that did it for me (Word 2011, clean-install of 10.7.2 off the Apple servers).
 
Comment

shirlee

macrumors newbie
Aug 26, 2015
2
0
I found a solution to this issue on the OfficeMac forums, but the post (or entire forum?!) had been removed some time ago. Luckily, Google had a cached version of the page from which I was able to extract the instructions provided by user "fafa." The updated summary of these instructions is as follows:

1. Make a backup of ~/Library/Preferences/com.microsoft.Word.plist
(Command + Shift + G from finder, paste in "~/Library/Preferences/" and click "Go", find com.microsoft.Word.plist and make a copy of it somewhere you can find it)

2. Open Terminal and paste the following:
Code:
defaults write ~/Library/Preferences/com.microsoft.Word.plist NSTextInsertionPointBlinkPeriod -int 500

The number at the end is the speed of your cursor in milliseconds; 500ms is the speed the cursor blinks in all of Apple's normal applications. I tested this myself and found it to work in Word 2011, even though the original guide was from Word 2008.

3. Restart Microsoft Word.
That's it!

The text from fafa's original post is quoted below, for posterity.
THANK YOU! (I set mine to 50ms)
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.