Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

chris001

macrumors regular
Original poster
Jan 31, 2008
130
0
Vancouver
hey guys.
i have upgraded my macbook to leopard. i have also uninstalled office 04 and installed office 08.
office 08 is alright but i'm having a major problem...

1. i have 4 spaces
2. space 1 = safari, space 2 = transmission, space 3 = OFFICE 08
3. when i open powerpoint/word (only ones i use) it comes up in space 3. this is fine.
PROBLEM;
sometimes my office automatically moves from spaces 3 to spaces 1. and i have to move it back to space 3. however, the format pallet stays in space 3 but the actual powerpoint/word window will move to space 1.

and sometimes my computer freezes for a good 3-4 seconds.

has neone else had this probelm? and if so, have you found the solution?
 

johny5

macrumors 6502a
Mar 31, 2007
750
11
UK
Have you tried forcing Office 08 to just using 1 space in the spaces prefs?
I seem to remember something similar on my setup and I just forced it into 1 space.
 

chris001

macrumors regular
Original poster
Jan 31, 2008
130
0
Vancouver
sorry johny i don't understand? forcing it to use space 1?

i'd like to keep all MS apps to space 3. as i like space 1 solely for safari.
 

burgen

macrumors newbie
Jan 9, 2007
29
0
It is a known problem that Office 08 is incompatible with spaces. MS or Apple will issue a patch to fix it, whenever that will be.
 

chris001

macrumors regular
Original poster
Jan 31, 2008
130
0
Vancouver
nuts. i thought i could so something to fix this.. oh well. i guess i'll just have to wait.

thanks burgen.
 

johny5

macrumors 6502a
Mar 31, 2007
750
11
UK
sorry johny i don't understand? forcing it to use space 1?

i'd like to keep all MS apps to space 3. as i like space 1 solely for safari.

In spaces prefs, just set Entourage or all of your MS apps to "space 3".
Like I said, this works fine for me.
 

Attachments

  • Picture 3.png
    Picture 3.png
    55.1 KB · Views: 194

chris001

macrumors regular
Original poster
Jan 31, 2008
130
0
Vancouver
how long do you use word and powerpoitn for? it usually happens 30mins in.

i've already set ALL ms apps to space 3.
it opens up in space 3 but the problem still occurs.
it's probably jsut a bug they havn't fixed yet. i'll wait for the update.
 

johny5

macrumors 6502a
Mar 31, 2007
750
11
UK
ah ok, sorry not sure then, I only open docs and close them again after about 10-20mins of editing.
Sounds like a weird bug if its doing that after 30 mins then :(
 

kallshian

macrumors newbie
Aug 28, 2008
1
0
I have this problem DAILY

This is a terrible problem and I keep thinking one of the Office 2008 updates will fix it, but alas, nothing has happened. It's basically unusable because you'll click on your document in Space 3, then it will whip you AND the formatting box into Space 1 or 2, then if you drag it back to Space 3 it will put your document behind another application and not allow you to select it. Then you have to jump back and forth between other Spaces until it decides to show you your document as normal again. Very inconsistent and frustrating.

I've tried everything I could think of, including deleting and then reassigning the application from a specific space. It just doesn't fix anything. The ONLY way to use the application normally is to disable spaces entirely, which for me is hardly an option because I LOVE Spaces. Microsoft needs to address this immediately! I know it's their problem because I've never had the issue with any other application except Office 2008 for Mac. :mad:
 

chris001

macrumors regular
Original poster
Jan 31, 2008
130
0
Vancouver
This is a terrible problem and I keep thinking one of the Office 2008 updates will fix it, but alas, nothing has happened. It's basically unusable because you'll click on your document in Space 3, then it will whip you AND the formatting box into Space 1 or 2, then if you drag it back to Space 3 it will put your document behind another application and not allow you to select it. Then you have to jump back and forth between other Spaces until it decides to show you your document as normal again. Very inconsistent and frustrating.

I've tried everything I could think of, including deleting and then reassigning the application from a specific space. It just doesn't fix anything. The ONLY way to use the application normally is to disable spaces entirely, which for me is hardly an option because I LOVE Spaces. Microsoft needs to address this immediately! I know it's their problem because I've never had the issue with any other application except Office 2008 for Mac. :mad:

exactly. FINALLY someone understands what i'm going through.
i also thought that the microsoft update would fix this problem. it obvs hasn't. i guess i'll just have to suck it up.
 

dws90

macrumors regular
Jan 16, 2008
122
0
It's a bit sad, really, that the Windows versions of Office have better Spaces support when run through coherence in Parallels than the native Mac versions do. I haven't tried Fusion in Unity mode, but I imagine that same thing would hold true there.

There is at least one other program that has the same problem, though. Circus Ponies' Notebook tends to want to keep all open notebooks in the same space, causing them to jump around if you move one.
 

walnuts

macrumors 6502a
Nov 8, 2007
572
281
Brooklyn, NY
I think I found a workaround for the spaces issue!

This is a terrible problem and I keep thinking one of the Office 2008 updates will fix it, but alas, nothing has happened. It's basically unusable because you'll click on your document in Space 3, then it will whip you AND the formatting box into Space 1 or 2, then if you drag it back to Space 3 it will put your document behind another application and not allow you to select it. Then you have to jump back and forth between other Spaces until it decides to show you your document as normal again. Very inconsistent and frustrating.

I've tried everything I could think of, including deleting and then reassigning the application from a specific space. It just doesn't fix anything. The ONLY way to use the application normally is to disable spaces entirely, which for me is hardly an option because I LOVE Spaces. Microsoft needs to address this immediately! I know it's their problem because I've never had the issue with any other application except Office 2008 for Mac. :mad:

So, I seem to have had the same problem as you all- and I think I found a workaround. Without knowing any programming, intuitively, the problem seems to be with the formatting bar. The bottom of the formatting bar seems to get detached from the the top and drift to other spaces. This happens almost every time you switch to a space other than the one with the Office app in it.

So, with the app being primarily in once space and its disassociated bottom part of the formatting bar in another, OS X gets confused as to which space to send you to when you reactivate your Office app and produces the bouncing around behavior and putting your active window behind others.

Here is the workaround that I found. If you set the formatting bar to collapse when inactive, it reduces to the top only of the formatting piece, thus not leaving the bottom part out to get lost in other spaces. As long as you change spaces after the bottom part of the formatting bar is collapsed, the office app behaves as it should.

I've now been working this way for several hours with word, bouncing between 6 spaces, have restarted, relaunched word, and still, finally, word and spaces have behaved as expected!

I am running 10.5.4 and Office 12.1.2.
 

walnuts

macrumors 6502a
Nov 8, 2007
572
281
Brooklyn, NY
sorry walnuts. but what does this mean? do you mean the dock?

can you please clarify? thanks.

Sure- there is a curly arrow in the upper right hand corner of the formatting pallette. If you press that, the panel turns around and gives display options (sort of like a widget). Check "When inactive for", choose your time setting (I suggest a short one- 5 seconds maybe), and click the "collapse" radio button (fade does not work).

Good luck- I hope it works!
 

chris001

macrumors regular
Original poster
Jan 31, 2008
130
0
Vancouver
Sure- there is a curly arrow in the upper right hand corner of the formatting pallette. If you press that, the panel turns around and gives display options (sort of like a widget). Check "When inactive for", choose your time setting (I suggest a short one- 5 seconds maybe), and click the "collapse" radio button (fade does not work).

Good luck- I hope it works!

Great i just figured out how to do it.
thanks!
hopefully this works.! i hope it will.
 

danny_w

macrumors 601
Mar 8, 2005
4,421
273
Cumming, GA
It is a known problem that Office 08 is incompatible with spaces. MS or Apple will issue a patch to fix it, whenever that will be.
Unfortunately the problem afflicts many more apps than just Office 2008: Fire2Fox (2 and 3), BBEdit, Office 2004, and NeoOffice, just to name a few. I'm sure I have also seen this occasionally with Safari and iWork '08.
 

suzerain

macrumors regular
Oct 5, 2000
196
0
Beijing, China
Unfortunately the problem afflicts many more apps than just Office 2008: Fire2Fox (2 and 3), BBEdit, Office 2004, and NeoOffice, just to name a few. I'm sure I have also seen this occasionally with Safari and iWork '08.

No, the Office one is unique. I use BBEdit and those ones also. BBEdit occasionally puts a window in the wrong space, but clicking on a window in the background doesn't whip you around to another space.

I think there are various Spaces-related problems, but there's also something unique about Office 2008 in this regard.
 

TheNorthWaves

macrumors 6502
Oct 13, 2007
329
18
USA
I am having the same exact problems listed above with 10.5.4 and office 12.1.2, and additionally:

- when I do command-save, it will frequently change spaces
- when i switch windows and return to word, the formatting pallette buttons disappear and the blinking cursor does not remain where it should be any longer.

I bought this computer and office 08 with the heavy interest in using office in spaces, so i'm actually really pissed off about this problem.

Apple? MS mac bu? anyone listening? Please fix this! Thank you.
 

chris001

macrumors regular
Original poster
Jan 31, 2008
130
0
Vancouver
Great i just figured out how to do it.
thanks!
hopefully this works.! i hope it will.

sigh. the fix you said...
When inactive for", choose your time setting (I suggest a short one- 5 seconds maybe), and click the "collapse" radio button (fade does not work).

it didn't work for me.

i go to school everyday, use my computer everyday. and it still happens EVERYDAY.

MS write the damn script to fix this.
 

absurdio

macrumors 6502
Aug 25, 2003
380
0
RI, Chi, and/or NY.
There's good news and bad news.
The good: this is a known issue. MS and Apple are both aware of it.
The bad: predictably, they aren't making any estimates about when they'll fix it.

Check this out (You might want to skip to the paragraph beginning "Bear with me while I shift gears now..."). It's a post written by a software designer at Microsoft's Mac Business Unit. The gist of it is that Microsoft and Apple are aware of the issue, but because of issues that are too technical for me to understand, there's no easy fix.

Also, here's a list of the symptoms of the Office/Spaces incompatibility, courtesy of Microsoft's Mac site, Mactopia. From the link:
  • When you switch between spaces, the Formatting Palette in Microsoft Word 2008 for Mac might move to another space.
  • When you drag open Word documents to two different spaces, they might relocate automatically to a single space.
  • Word might open in front of other application windows that are running in the active space.
  • When you switch to the space assigned to Word, an open Word document might be hidden behind other active application windows, and clicking in the document or on the document window toolbar might not bring the document to the foreground.
  • Office 2008 for Mac applications might quit unexpectedly.
Basically, this is all sortof frustrating and infuriating to me. Those glitches listed by Microsoft are a pretty big deal. They make the software a lot less usable and seriously detract from the overall product experience. How they can continue to market Office 2008 as a finished product - all the while acknowledging this whole host of problems and making no indication at all that they'll be fixed any time soon - is baffling to me.
 

Furgster

macrumors 6502
Jun 16, 2007
260
1
ok, this problem is seriously horrible, it is now the end of january and MS still has not issued a fix for it. this is not apple's responsibilty it is Microsoft's! how could they even release a product that has a problem as serious as this, just another reason to never buy anything made by M$ ever again...:mad:

Edit: are you serious? this problem has been around for a year and they havent done anything about, what a load of idiots up at redmond
 

Mr. Zarniwoop

macrumors 6502a
Jun 9, 2005
752
139
Work-around

I set Excel, PowerPoint and Word to "Every Space". It's not optimal, but better than the disaster of spaces moving around on me in ways that make no sense. It at least lets me get my work done without the formatting palette moving into a different space or Word jumping one documents across spaces.

Entourage seems to "live" in one space comfortably without issues for me.
 

thesame3songs

macrumors newbie
Feb 26, 2009
2
0
Formatting Pallette Fix Worked For Me

Sure- there is a curly arrow in the upper right hand corner of the formatting pallette. If you press that, the panel turns around and gives display options (sort of like a widget). Check "When inactive for", choose your time setting (I suggest a short one- 5 seconds maybe), and click the "collapse" radio button (fade does not work).

Good luck- I hope it works!


I confirm this fix worked on my Macbook with Leopard 10.5.6, Word 2008, and Spaces 1.0. Thanks!
 

chris001

macrumors regular
Original poster
Jan 31, 2008
130
0
Vancouver
I confirm this fix worked on my Macbook with Leopard 10.5.6, Word 2008, and Spaces 1.0. Thanks!

i've done this.
it DOESN'T solve the problem but it helps.

the application doesn't jump as often.

oh well.
no biggie anymore. i'm not using .ppt this term =D
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.