Office 2008 lagging?

Discussion in 'Mac Basics and Help' started by acearchie, Mar 17, 2008.

  1. acearchie macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #1
    Just installed it on my powerbook G4 1.5GHz 512mb of ram (with a 1gb stick in the post, will this make a difference?)

    The program is very laggy when clicking arrows to move along pages of charts, wordart, smartart graphics etc...

    Even typing is laggy (i.e not fluid like I write this post now!)

    Anyone have any ideas or solutions?
     
  2. Mindflux macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
    #2
    get a new box, no really.

    I thought 2008 was Intel only? Does Rosetta allow you to run Intel binaries on a PPC system (and vice versa)?
     
  3. Moof1904 macrumors 65816

    Joined:
    May 20, 2004
    #3
    No, it's universal binary. It runs fine on my G5. Well, it could be faster and it could suck less, but it runs...
     
  4. Doctor Q Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #4
    I have the same problem. It's slower than previous versions on every Mac I've run it on. I'm sorry I ever upgraded to Office 2008.
     
  5. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #5
    I reckon an update might be able to solve some issues maybe? . . .
     
  6. joeconvert macrumors 6502

    Joined:
    Nov 18, 2003
    Location:
    TX
    #6
    Hey DQ, what have you run it on? My copy is going to be delivered today and am getting a bit more concerned about usability.....
     
  7. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #7
    Lets keep our fingers crossed that the update fixes this. I have an MBP 2.33 and it still feels slower than 2004 to me. The initial delay when Word first opens is especially bad. I can type whole sentences after the blank document shows up before they appear on the screen...
     
  8. Doctor Q Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #8
    The machine I tested with is an 1.8GHz 20" iMac, pre-Intel.
     
  9. joeconvert macrumors 6502

    Joined:
    Nov 18, 2003
    Location:
    TX
    #9
    Thanks, appreciate the feedback.
     
  10. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #10
    I know I had a similar experiance in the Apple Shop today with a brand new MBP!
     

Share This Page