Office 2016 - can't load visual basic for applications

xadros

macrumors member
Original poster
Oct 4, 2014
52
6
Hello, i was very happy with using Office 2016 preview but i needed to use migration assistant and after that, it don't work. I still get can't load visual basic for applications message and office crashes. I tried remove based on steps for "complete removal office 2011" but it still don't work.
 

campyguy

macrumors 68040
Mar 21, 2014
3,413
953
OP, VBA in Office 2016 is not fully implemented yet, and VBA needs to be "activated" in each app it's used in; "activation", in my words, means that MS has provided Resource files in the Word app in the language and my installations of Office 2016 do have Russian Language Resources in the VB engine - whether this has been enabled by MS is another matter. VB in existing documents did not work for me until I enabled the Developer Tab, which is hidden by default.

For instance (using English to describe the following, as it's my main spoken language), in Word's Preferences Pane choose the "View" option (second from the left in the top row) and then enable/check the "Developer Tab" (second from the bottom in the View Preference Pane) and close the Word Preference Pane.

Choosing the Developer Tab reveals VB options. I've performed some simple programming in the interface and it works as expected; I am not investing much time in Office 2016 as it's a preview, but I can offer that VBA is working on the 3 Macs I've installed it on. Good luck!
 

Swevain

macrumors member
May 29, 2010
33
1
Malmö
I have the same problem. I "solved" it by removing the non-english letters from the foldernames where the word file is. For example, I had a folder named Gruppövningar and I couldn't open any file in that folder. So I renamed it to Gruppovningar and suddenly it works.
 

campyguy

macrumors 68040
Mar 21, 2014
3,413
953
I have the same problem. I "solved" it by removing the non-english letters from the foldernames where the word file is. For example, I had a folder named Gruppövningar and I couldn't open any file in that folder. So I renamed it to Gruppovningar and suddenly it works.
I respectfully disagree that you have the same problem, but that you have a common and long-standing problem with using the same character encoding - and that your issue may yet be addressed in a future build. I recall having to address the same problem you're describing as far back as Office 98/97 (Mac/Win, respectively) - and I know that Apple went as far to post a filename conversion utility - for OS 9 (https://support.apple.com/kb/DL355?viewlocale=en_US&locale=en_US) - on their website to ensure that filenames created on other platforms could be converted in batches to Unicode.

Your problem with diacriticals affects many XML-based applications - including Sharepoint, Project, BBEdit, Word, Excel, (several versions of) SAS, Google Chrome, and so many others. Try searching for a web site with Chrome that offers up words with "ö" in it - then use the Find command for that character, and you'll find that every single "o" is highlighted. Annoying, that. And, I'm part Swedish, so I get it...

Search the internet for "xml encoding problem" and you'll get an idea of how far back this file naming issue goes back, especially with file exchanges between Unicode and UTF-8/16 encoding.

Office stores the filename in a hidden header, in the file encoding format you've designated. If your file's text encoding is different than the OS that created the destination (folders), you'll likely have the "I can't find the file you want" dialog (I'm not being literal with this). Any time one uses a diaeresis or other diacritical in a filename, the file system and OS system must be either compatible or the applications you're using can automatically pick up encoding (like TextEdit). That "ö" is digitally interpreted so many ways - http://graphemica.com/ö - make sure your Mac is talking appropriately to its applications!
 

xadros

macrumors member
Original poster
Oct 4, 2014
52
6
Thank you! and if i tried so many times uninstalling etc. I see this in launchpad - it opens powerpoint 2011 as default, i can launch powerpoint 2016 only from applications folder. Is there any way to solve it or how can i make complete reinstall of Office 2011 and 2016, i don't want to have my mac messy. thank you.
 

hlamar

macrumors newbie
Jan 1, 2016
3
0
OP, VBA in Office 2016 is not fully implemented yet, and VBA needs to be "activated" in each app it's used in; "activation", in my words, means that MS has provided Resource files in the Word app in the language and my installations of Office 2016 do have Russian Language Resources in the VB engine - whether this has been enabled by MS is another matter. VB in existing documents did not work for me until I enabled the Developer Tab, which is hidden by default.

For instance (using English to describe the following, as it's my main spoken language), in Word's Preferences Pane choose the "View" option (second from the left in the top row) and then enable/check the "Developer Tab" (second from the bottom in the View Preference Pane) and close the Word Preference Pane.

Choosing the Developer Tab reveals VB options. I've performed some simple programming in the interface and it works as expected; I am not investing much time in Office 2016 as it's a preview, but I can offer that VBA is working on the 3 Macs I've installed it on. Good luck!

What about microsoft office 2011 version of word? i'm having this problem with this version and i can't find developer tab.

I'm having a problem with this message in microsoft office 2011 word, can't load visual basic for applications. how can i solve it w/o reinstall as i don't know where the discs are for 2011?
 
Last edited by a moderator:

campyguy

macrumors 68040
Mar 21, 2014
3,413
953
What about microsoft office 2011 version of word? i'm having this problem with this version and i can't find developer tab.
Word > Ribbon Preferences… (the Gear at the right of the Ribbon) > Customize options > Developer Checkbox Option (at the bottom). Quit Word, and restart Word.
 

chrfr

macrumors G3
Jul 11, 2009
9,884
3,693
also i tried deletng the preferences for visual basic. I can't find my discs to reinstall or uninstall. thinking of just switching to office 365 anyways.
I have no idea if it will solve your problem but the person who maintains this page has put together a list of Office 2011 installers. https://www.heidoc.net/joomla/techn.../61-office-2011-for-mac-direct-download-links
You may need your product code, but you may not since Office is already activated on that computer.
 

hlamar

macrumors newbie
Jan 1, 2016
3
0
Word > Ribbon Preferences… (the Gear at the right of the Ribbon) > Customize options > Developer Checkbox Option (at the bottom). Quit Word, and restart Word.
i did this, checked the developer box, then restarted. i still got the message!
 

campyguy

macrumors 68040
Mar 21, 2014
3,413
953
i did this, checked the developer box, then restarted. i still got the message!
The only remaining suggestion I have just to check the name of your hard drive in the name of any and all folders leading into the path of your files. Microsoft's Applications prohibit the use of certain characters in filenames, especially those that are referenced. Use Microsoft's Help to help you determine which offending characters are in the files path and/or filename. Also, if any of the offending/illegal characters are referenced in a visual basic macro, then you'll get error messages. In the visual basic macro, basically, you're debugging the code. In Finder, you're basically adhering to Microsoft's requirements for filenames.
 

kernric

macrumors newbie
Mar 11, 2016
2
2
What about microsoft office 2011 version of word? i'm having this problem with this version and i can't find developer tab.

I'm having a problem with this message in microsoft office 2011 word, can't load visual basic for applications. how can i solve it w/o reinstall as i don't know where the discs are for 2011?
[doublepost=1457726407][/doublepost]This solved the problem for me in Office 2011.
Delete the linkCreation.dotm file located here:
~/Applications/Microsoft Office 2011/Office/Startup/Word/linkCreation.dotm

The file can somehow re-create itself (rarely, only happened once since I figured this out about a month ago), sometimes after opening word docs from other users, and/or when Office pushes through updates. This causes the error message again -- just go back and delete linkCreation.dotm and you should be good again.

Note: Unchecking the box next to linkCreation.dotm in the file menu Templates and Add-ins under Global templates and add-ins will not fix this. You must delete the file as indicated above.

Initially I first deleted the normal.dotm file before deleting linkCreation.dotm, then rebooted. That fixed also, but I've found that simply deleting linkCreation.dotm does the trick. No reboot required.

HTH
 
Last edited:

Berniesp2

macrumors newbie
Apr 14, 2016
1
0
I didn't think Office 2016 even uses Visual Basic anymore.
[doublepost=1460674460][/doublepost]Interesting, after office 2016 and fresh install of Dragon Dictate rev 4.73 I Got
"Install Visual Basic for Applications.framework using your Office installer"
 

Wait...What?

macrumors newbie
May 9, 2016
1
0
[doublepost=1457726407][/doublepost]This solved the problem for me in Office 2011.
Delete the linkCreation.dotm file located here:
~/Applications/Microsoft Office 2011/Office/Startup/Word/linkCreation.dotm

The file can somehow re-create itself (rarely, only happened once since I figured this out about a month ago), sometimes after opening word docs from other users, and/or when Office pushes through updates. This causes the error message again -- just go back and delete linkCreation.dotm and you should be good again.

Note: Unchecking the box next to linkCreation.dotm in the file menu Templates and Add-ins under Global templates and add-ins will not fix this. You must delete the file as indicated above.

Initially I first deleted the normal.dotm file before deleting linkCreation.dotm, then rebooted. That fixed also, but I've found that simply deleting linkCreation.dotm does the trick. No reboot required.

HTH
[doublepost=1462847424][/doublepost]Worked perfect thanks!
 

Efrem

macrumors regular
Jul 30, 2009
112
15
[doublepost=1457726407][/doublepost]This solved the problem for me in Office 2011.
Delete the linkCreation.dotm file located here:
~/Applications/Microsoft Office 2011/Office/Startup/Word/linkCreation.dotm

...
Thank you! This has been bugging me for a while. It was never disabling, I just had to dismiss error messages whenever I launched or quit Word, but it was annoying. Problem solved!
 

jlauve

macrumors newbie
Jul 26, 2008
7
0
[doublepost=1457726407][/doublepost]This solved the problem for me in Office 2011.
Delete the linkCreation.dotm file located here:
~/Applications/Microsoft Office 2011/Office/Startup/Word/linkCreation.dotm

The file can somehow re-create itself (rarely, only happened once since I figured this out about a month ago), sometimes after opening word docs from other users, and/or when Office pushes through updates. This causes the error message again -- just go back and delete linkCreation.dotm and you should be good again.

Note: Unchecking the box next to linkCreation.dotm in the file menu Templates and Add-ins under Global templates and add-ins will not fix this. You must delete the file as indicated above.

Initially I first deleted the normal.dotm file before deleting linkCreation.dotm, then rebooted. That fixed also, but I've found that simply deleting linkCreation.dotm does the trick. No reboot required.

HTH
I too had this problem. Deleting the linkCreation.dotm file fixed it. Thank you so much.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.