Office 2016 slow typing

Discussion in 'Mac Apps and Mac App Store' started by iEric007, Aug 10, 2015.

  1. iEric007 macrumors regular

    iEric007

    Joined:
    Jan 29, 2007
    Location:
    Orange County, California
    #1
    I upgraded to Office 2016 and I have to say Word is super slow when it comes to typing. Like it lags behind each word when I type. And, its worse when I type in a table. It's driving me crazy. Is anyone else experiencing this? It's the same for me on my Macbook Pro or Mac Mini. And, the slow typing on a table is also there on Word 2016 for iPad.
     
  2. Toltepeceno Suspended

    Toltepeceno

    Joined:
    Jul 17, 2012
    Location:
    SMT, Edo MX, MX
    #2
    Odd, it's not happening to me on mac mini or ipad mini.
     
  3. Significant1 macrumors 6502

    Joined:
    Dec 20, 2014
    #3
    Isn't just because Microsoft has made the movement smooth?

    I already deleted mine and can't remember, but recall that is how the latest version on Windows, I tried, behaved.
     
  4. snowydog macrumors 6502

    Joined:
    Aug 25, 2011
    #4
    Mine is the same and it's very annoying - all my work is report writing and it's a nuisance....I type too fast for word / powerpoint and it's just annoying the life out of me. I thought it was maybe just the beta version but got a new Macbook and got Office for Mac 2016 and it's still the same.

    In addition to this .. I have a problem where I'm typing in a table in Powerpoint and come to the end of the line - naturally powerpoint should just continue my sentence on the next line but it seems to be highlighting the whole cell text and then as I am typing faster, it is overriding the cell text .. I keep having to use undo and be careful when I come to the end of a line ... also same thing happens when I press enter for a new para in powerpoint ... highlights the whole cell text and overrides it ... again I have to use the undo and work around it ... I really hope this isn't it .. they better have updates to fix these few things.

    I'd love to use iWork or Keynote but unfortunately we have standard templates for our reports at work and most people operate from a windows machine so I have to go with Microsoft Office for now.
     
  5. FoxyKaye macrumors 68000

    FoxyKaye

    Joined:
    Jan 23, 2004
    Location:
    San Francisco, Terre d'Ange, Bas Lag, Gallifrey
    #5
    Same issue here - Word, in particular, is laggy on typing. And, Excel is awful on text rendering -- this happens on both my MBAs.
     
  6. vkd macrumors 6502a

    vkd

    Joined:
    Sep 10, 2012
    #6
    Why not just stop obsessive and/or addicted use of M$ products? Apple Pages works, believe it or not. OK in Word there are millions of useless functions that hardly anybody ever uses, or use once in a curious test and then never again, but so what?
     
  7. bearwise55 macrumors newbie

    Joined:
    Aug 17, 2015
    #7
    Very slow here. Im entering text in draft mode now, at least it goes faster.
     
  8. jsavvy macrumors member

    jsavvy

    Joined:
    Aug 19, 2011
    #8
    I have the same issue from time to time on my MBA. Word 2016 usually crashes on the first attempt to open it. Then, I get the random slow, laggy typing.

    For those wondering why not just use Pages, Word has better spell/grammar check. I've copied countless papers that showed no issues in Pages into Word only to have Word point out a simple mistake. Word also has better citation tools than Pages out of the box.
     
  9. Significant1 macrumors 6502

    Joined:
    Dec 20, 2014
    #9
    Why not stick to Word 2011. Unless you are using collaboration, Word 2016 is just dumped down version compared to Word 2011. That is why I can't check the typing speed here, because it was a step back and I removed it.
     
  10. starless macrumors newbie

    Joined:
    Nov 28, 2008
    Location:
    Rome, Italy
    #10
    Hi, did you ever find a solution to this problem?
    I started using Office 2016 recently on my MacBook Pro running Yosemite, and Word can sometimes be very very slow while typing. Luckily it seems to be limited to documents saved in the old .doc format, but it's an annoyance nevertheless.

    Thank you.
    Marco
     
  11. macboydus macrumors newbie

    Joined:
    Jan 7, 2009
    #11
    Yep this issue is pretty annoying - here's one thing that helps a lot for me, I just changed the view to Draft - seems to make a huge difference....hope that helps you lot ;)
     
  12. iEric007 thread starter macrumors regular

    iEric007

    Joined:
    Jan 29, 2007
    Location:
    Orange County, California
    #12
    Thanks for the tip. I'll definitely try it. (Still experiencing the issue since I posted this back in Aug 2015.)
     
  13. lynettediaz17 macrumors newbie

    lynettediaz17

    Joined:
    Apr 18, 2016
    #13
    yes I have this very problem!! I hate it. Its driving me absolutely insane!!
    --- Post Merged, Apr 18, 2016 ---
    This helped!!!!!!!! Thank you so much!!! Holy smokes! So glad I didn't give up looking for a solution!
     
  14. lukejanicke macrumors newbie

    Joined:
    Jun 20, 2016
    #14
    Same problem. You type, and seconds later the letters appear.

    I found the problem only occurs if the document is saved in .docx format. If you save as Word 97–2004 Document (.doc) there is no typing delay. But then you're limited to the older formatting and features of Word, which can be even more infuriating.

    For those who say just use Apple Pages, I agree. And I have been for the last 4 years. Until now, I need the equation editor in Word to collaborate with my colleagues.
     
  15. lukejanicke, Jun 21, 2016
    Last edited: Jun 21, 2016

    lukejanicke macrumors newbie

    Joined:
    Jun 20, 2016
    #15
    Solution:
    1. Quit Magnet.
    2. Remove Magnet from your login items.

    There’s a discussion here:
    Word Mac 2016: Type words extremely slow with table in the same page

    Where someone posted a link to this Microsoft support article:
    How to use a "clean startup" to determine whether background programs are interfering with Office for Mac

    It worked for me and the culprit item was Magnet. I sent a message to the developers of Magnet to advise them of the conflict.

    However, there may be other applications that cause the same problem.

    In which case…
    1. Go to System Preferences > Users & Groups > Login Items.
    2. Select them all (not the checkboxes) and click the remove button below the list.
    3. Restart the computer.
    If this worked for you, please post which program was the culprit.
     
  16. starless macrumors newbie

    Joined:
    Nov 28, 2008
    Location:
    Rome, Italy
    #16
    This is very strange: as I wrote in my previous post, my feeling is exactly the opposite!
    On my MacBook the problem is more present in files where "Compatibility mode" is shown in the title bar, i.e. .doc files and .docx files saved with compatibility option active.
    I can say, for sure, that in some cases I had the problem with a "compatibility mode" file, I saved it as standard .docx, and the problem disappeared.

    But anyway based on my tests the issue is not limited to that.
    I have some files with a not-basic layout, long tables etc., where typing is very slow even in docx format.
    I also tried starting my Mac in safe/clean mode but the problem remained, so it's not caused by background apps.

    It's true that draft mode speeds up typing quite a lot, but then we're going back 20 years before real WYSIWYG was here... it's not a solution.
     
  17. henricusdatu macrumors newbie

    Joined:
    Sep 20, 2016
    #17
    I have the same problem, but it only happen to files that open in the "compatibility mode" (can be seen on the top bar, next to the file name). Then simply I convert the document (file > convert document), and the problem disappear.
     
  18. cdcastillo macrumors 6502a

    cdcastillo

    Joined:
    Dec 22, 2007
    Location:
    The cesspit of civilization
    #18
    Because they are forced to do so by work requirements? If you had read the posts before yours, you'd realize that. Some of them are not in liberty of doing what they want and are asking for help, your post is not helping them.
     
  19. Tarek macrumors 6502

    Joined:
    Jun 25, 2009
    Location:
    Cairo, Egypt
    #19
    I have the same problem. It seems as though I type too fast for word to handle so there is a bit of a delay in the time the text appears on the screen, from several tests my typing speed appears to be 140wpm. It's not a huge annoyance because I don't do a lot of typing in the time being, but I can see it becoming one very soon when I get back to work. Are there any actual workarounds at the moment?
     
  20. chino101 macrumors newbie

    chino101

    Joined:
    Dec 8, 2015
    #20
    I have the exact same problem on my RMbP13. It's not text smoothing, as sometimes it is fine and at others it is not.

    I switched to 2016 because of the annoying disappearing footnotes saga with Word 2011, but Word 2016 is even more annoying with the delayed typing!

    Hopefully MS put out a fix!
     
  21. peterfc macrumors newbie

    Joined:
    May 10, 2011
    #21
    Yes have the same problem occurring somewhat randomly but most often with long documents (+50 pages). I would'n't hold my breath waiting for Microsoft to fix it; Word 2016 has been out for a year and even updated to 64 bit, without any noticeable performance improvements. It is incredible that they cannot make a decent version of one of the most popular applications on the Mac and I have gone back to Word 2011. Word on Windows is just so much better even on very low spec hardware, but I like the Mac hardward and iPhone integration.
     
  22. YB1 macrumors newbie

    Joined:
    Sep 29, 2016
  23. Ericplan macrumors newbie

    Ericplan

    Joined:
    Oct 21, 2016
    Location:
    Amsterdam
    #23
    Did you ever take a look at the application size?
    • Word 2011 56,7 MB
    • Word 2016 1,91 GB
    To me it is completely clear why this program is sooooooo slooooow.
     
  24. loby macrumors 6502a

    loby

    Joined:
    Jul 1, 2010
    #24
    I think it might be that Microsoft records every keystroke now. I see the same thing in equivalence with the Windows version. Slow typing on screen. No reason for this except if the program is recording in my opinion. Read Microsoft's user agreement. They will say what they do things like this too "improve" their products.. yeah sure.
     
  25. Silvestru Hosszu macrumors member

    Joined:
    Oct 2, 2016
    Location:
    Arad, Romania
    #25
    Very strange, I'm using ms office 2016 on a MacBook, MacBook pro 15'' 2015 and on iMac 2012.
    Not one issue on any of the above mentioned computers.
     

Share This Page