• Did you order new AirTags? We've opened a dedicated AirTags forum.

ScottNWDW

macrumors 65816
Original poster
Jul 10, 2008
1,226
301
Orlando, Florida
I recently got a new MacBook Pro and I downloaded Office 365 Home Edition. After logging in to my account everything works just great with the exception of Excel not saving files without first having to rename the file. The message that I receive says;

With Auto Save function turned on I get an alert that says:
"Can't Save There was a problem saving and Auto Save was disabled. Please Save As or close and reopen the file. "

When I try to save with Auto Save turned off I get the following alert:
"The document was saved successfully, but Excel cannot re-open it it because of sharing violation. Please close the document and try to open it again"

Word, PowerPoint, One Note and Outlook work perfectly. The issue only occurs with Excel.

The files work perfectly on my iMac, and they also work perfectly on my iPhone and iPad. It's only in the MacBook Pro that it is not working. Both iMac and MacBook Pro are using MacOS 10.14.6 and Excel version 16.29 (19082004)

Any ideas what could be causing this. I've tried uninstalling and reinstalling it, but with the same results all the time.
 
Last edited:

ScottNWDW

macrumors 65816
Original poster
Jul 10, 2008
1,226
301
Orlando, Florida
It's not just OneDrive, the same behavior happens with iCloud Drive as of the latest Excel update from the App Store.

I thought it was odd because it works perfectly fine on my iMac. Both devices have the same version number and were downloaded directly from Microsoft,not the App Store. Hopefully the next update will fix it.
 
Comment

AVonGauss

macrumors 6502
Oct 6, 2006
321
85
Boynton Beach, FL
I thought it was odd because it works perfectly fine on my iMac. Both devices have the same version number and were downloaded directly from Microsoft,not the App Store. Hopefully the next update will fix it.

I really hadn't put much effort in to resolving the issue as I'm running Catalina on the desktop where Excel is used, but for me, just now deleting Excel and reinstalling it from the App Store solved the problem. I can now save to iCloud without the warning and if I try to save it more than once I'm no longer forced to save it as a copy.
 
Comment

ScottNWDW

macrumors 65816
Original poster
Jul 10, 2008
1,226
301
Orlando, Florida
I really hadn't put much effort in to resolving the issue as I'm running Catalina on the desktop where Excel is used, but for me, just now deleting Excel and reinstalling it from the App Store solved the problem. I can now save to iCloud without the warning and if I try to save it more than once I'm no longer forced to save it as a copy.
I may have to try that.
 
Comment

ScottNWDW

macrumors 65816
Original poster
Jul 10, 2008
1,226
301
Orlando, Florida
I take that back, last night it wasn't showing the error after reinstalling but it is now doing so again this morning.
I response that I received on the Microsoft Website suggested that I go into the System Preferences and check the Security and Privacy settings under Full Disk Access. I went there and it listed both OneDrive and Excel as turned off. I clicked them both on, and the issue seems to be resolved. Excel is working just fine like it was before. ;-)
 
  • Like
Reactions: larryleveen
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.