Office and UK English

Discussion in 'Mac Apps and Mac App Store' started by kolax, Nov 5, 2010.

  1. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #1
    This is frustrating me so much. Office refuses to use the UK English dictionary, even though it is selected in the preferences. Things like visualisation get underlined.

    I had problems with this in Office 2008, and it still persists in Office 2011.

    Anyone else having issues with this?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    What language do you have selected in System Preferences > International?
     
  3. kolax thread starter macrumors G3

    Joined:
    Mar 20, 2007
    #3
    Under Languages and Text I have British English.

    Don't understand why that'd make a difference if Office has its own dictionary that it uses though.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Just checking. In Word, I assume you've selected English (UK) from Tools > Language... menu, right?
     
  5. kolax thread starter macrumors G3

    Joined:
    Mar 20, 2007
    #5
    Hmm. Keeps reverting back to English (US), even though I select English (UK).

    Can't believe how many places I have to change it.. dictionary and language? Can't Microsoft just combine it all into one place. Why would I want a UK English Dictionary and a US English spellcheck?!
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    I know. That's Microsoft for you. You might try creating a new document, making your language choices, then saving the document as your new Normal template.
     
  7. kolax thread starter macrumors G3

    Joined:
    Mar 20, 2007
    #7
    Good idea, and I think that works for any new documents that I open.

    However, if I open a previous document, it reverts back to US English!
     
  8. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    Try this:
    1. Open a Word doc and highlight some text.
    2. Select Tools > Language...
    3. Select English (UK)
    4. You should be able to select Default.
    ScreenCap 6.PNG
     
  9. kolax thread starter macrumors G3

    Joined:
    Mar 20, 2007
    #9
    Tried that - still uses the US spelling!

    I change it to UK English (clicking default, like in your screenshot), and as soon as I start typing it goes back to US English!

    Thanks for trying to help.
     
  10. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #10
    I guess you should just move to the US! :D I'm out of ideas.
     
  11. Scepticalscribe Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #11
    I have had that problem, too, with versions of Office which persisted in selecting American English to my intense frustration.

    Cheers
     
  12. Dal123 macrumors 6502a

    Dal123

    Joined:
    Oct 23, 2008
    Location:
    England
    #12
    This is a problem that mac, not just microsoft needs to address - I think. I use the dictionary feature on mac quite frequently, however you like you say it just is not good enough with british english :(.
     
  13. amt2002 macrumors member

    Joined:
    Jul 18, 2008
    #13
    Just thought I'd say I'm suffering this issue too, but have noticed something else a bit odd.

    Going to TOOLS > LANGUAGE fixes this, but only for a short time then it'll click back to US.

    So I tried something else. I clicked SPELLING> OPTIONS > DICTIONARIES. Changed Language to English (UK) and clicked ok. But that mean's I can no longer 'add' words to the dictionary from my document.

    Bizarre.
     

Share This Page