Office for Mac - Excel Toolbars

Discussion in 'Mac Apps and Mac App Store' started by BitterB, Jan 10, 2009.

  1. BitterB macrumors member

    Joined:
    Apr 22, 2007
    #1
    This is driving me nuts.....does anyone know how to set the Excel (2008 version) toolbars at top of app to remain as a saved preference? I've tried everything and when I quit Excel and re-open, everything I've changed about the toolbar view is gone and I'm left with nothing. It wasn't like this all along, and somehow I ended up this way. Please help.....and not by telling me to ditch Excel and go for Open Office or something else.....because I need Excel to work for me.

    Many thanks.
    :cool:
     
  2. Heb1228 macrumors 68020

    Heb1228

    Joined:
    Feb 3, 2004
    Location:
    Virginia Beach, VA
    #2
    I wish I could help, Excel toolbars have been giving me a fit recently too.

    It sounds like a preference file may be set to read-only for you. Are all your other preferences resetting too or just toolbars? I'm not sure where the info in stored, try looking around at Library/Preferences/com.microsoft.Excel.plist and similar files to see if permissions are correct. You might try running repair permissions (in Disk Utility). I'm not sure if it would help in this case or not. That's the first place I'd check.
     
  3. Gray-Wolf macrumors 68030

    Gray-Wolf

    Joined:
    Apr 19, 2008
    Location:
    Pandora, Home Tree
    #3
    Just did a test on mine, it all stays where I put it, other than full screen :D

    I changed a few things, closed and opened several time, right where I left it.
     

    Attached Files:

  4. macrem macrumors 65816

    macrem

    Joined:
    Mar 11, 2008
    #4
    Wish I could help. I have OpenOffice, which can open/save .xls and costs $0, but alas toolbars stay the way you set them.
     
  5. jive turkey macrumors 6502

    Joined:
    Mar 15, 2008
    #5
    I have all kinds of fits with Excel toolbars that show up when I switch Spaces. For instance, I have Excel set up to always work on Space 5. Sometimes I will be working on Excel, switch to Space 4, and the toolbar vanishes. I later find it hiding behind all open windows on Space 4, and I can't click it because when I try to it moves me back to the normal Excel app on Space 5. Turning the toolbars off and back on doesn't help any. I have to quit out of Excel to get the thing back where it belongs.

    Long story short, if you are using Spaces that may be the problem. Office and Spaces is a bad combo on my machine.
     
  6. SecrtAgnt macrumors newbie

    Joined:
    Sep 16, 2009
    #6
    BUMP - I have the same issue



    I don't have "Library/Preferences/com.microsoft.Excel.plist" :eek:

    Does anyone know what I could do to get the settings to save?
     
  7. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #7
    You do have com.microsoft.Excel.plist or maybe com.microsoft.Excel.prefs.plist somewhere.

    Try adding YourUserFolder and Microsoft to the path:
    Users/YourUserFolder/Library/Preferences/Microsoft

    That's where it's found in Leopard. I have 10.5.8

    Find it, and drag it to the Desktop
    Fire up Excel
    A new plist file for Excel will be created in the Microsoft folder (above path)
    You will now be back to Excel defaults
    Make a change to a toolbar, and see if it sticks
    If not, you can always put the file on your Desktop back
    You can overwrite the default file
    It's easy to remake it, as you've seen
     
  8. SecrtAgnt macrumors newbie

    Joined:
    Sep 16, 2009
    #8
    Thanks Gregg2


    I followed your advice...
    When I moved it to me desktop and it created a new default, I noticed something.
    Under view>toolbars>Standard (and formatting) are both check marked.
    I have to un-checkmark them and re-checkmark them to get the tool bar to show up.

    Any thoughts?

    OS X - 10.5.8
    MS Excel 2008 for Mac
    Version: 12.2.3
     
  9. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #9
    Are you sure Excel is the active application when the toolbars are not visible? If it says Excel in the upper left, and they are checked but not visible, that is not normal. But, if it says Finder or something besides Excel up there, then invisible toolbars is normal.

    The toolbars are supposed to remain in the state you have them when you Quit out of Excel (or Word). That plist trick is the only simple thing I can think of that might cure this "forgetfulness" you're seeing. The next step might be to reinstall Excel. ...if no one else has another simple trick to try. (I don't think a new User Account or Repairing Permissions, two tricks commonly suggested, apply in this situation.)
     
  10. rowsdower macrumors 6502

    Joined:
    Jun 2, 2009
    #10
    This is extremely frustrating to me as well. In my experience, if you can find the toolbar and you click and hold the normal drag area (the part of the toolbar that allows you to drag it, I don't know what else to call it), it will bring you back to the Space where the main Excel program is running, along with the toolbar.
     
  11. SecrtAgnt macrumors newbie

    Joined:
    Sep 16, 2009
    #11
    Yes, it is definitely the active program.


    Any other thoughts?
    If not I guess I'll have to reinstall.

    Thanks for the help!
     
  12. topmounter macrumors 68020

    topmounter

    Joined:
    Jun 18, 2009
    Location:
    FEMA Region VIII
    #13
    I don't know if this is any help since most of my issues related to using Spaces, but Office Apps are far better behaved in Snow Leopard than they were in Leopard.
     
  13. SecrtAgnt macrumors newbie

    Joined:
    Sep 16, 2009
    #14
    update

    When I use MS Excel under the "guest account" on the same machine I do not experience this issue. I also changed the settings several different ways and after closing the program and re-opening the settings remained as they were left upon exiting.

    Is this a user issue or MS Excel issue?
     
  14. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #15
    you beat me to it!

    Trying a different User Account was going to be my next suggestion. Creating a new Main Administrator Account can be a pain. (I've never had to.) You have to move your stuff before you can delete the corrupt one. Mac Help has some guidance to offer. But, you might want to create another new account just to be sure that it works there. Two against one gives you much better odds that a permanent switch will solve the problem. Unfortunately, I don't know how to fix your account, if it is indeed corrupt. It's just one of those unsolved mysteries, like corrupt plist files.
     
  15. polina macrumors newbie

    Joined:
    Dec 29, 2009
    #16
    if i understood your problem right - i had the same thing that was killing me all the time: i needed toolbars for highlighting and so on but every time i was opening new work book - i was choosing view -then toolbars-then formatting (although it was already ticked) - so i untick it - then tick it again - so it would appear on the top of my excel sheet.
    finally i realized that i need to leave "formatting" ticked and just tick some grey button in the upper right corner so now every time i open new excel work book the toolbar is on the top of the excel sheet and stays there. :)
     
  16. SecrtAgnt macrumors newbie

    Joined:
    Sep 16, 2009
    #17

    Polina - THANK YOU!!!
    The little ticktac in top right hand corner was hiding the menus.
    Thanks for sharing your solutions and ending my ongoing annoyance!
    Cheers to you :)
     
  17. GakonaClair macrumors newbie

    Joined:
    Feb 2, 2010
    #18
    thanks for the short solution

    SecrtAgnt & Polina,
    Thanks so much for this solution. It's been driving me nuts! While I think Excel should be smart enough to keep the toolbars visible in between sessions, your solution of a single click to make them appear is far easier that the tedious View work around. Thanks!
    Clair
     

Share This Page