Official 2nd gen IPT and Album art thread..

Discussion in 'iPod touch' started by Gix1k, Oct 1, 2008.

  1. Gix1k macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
    #1
    Why doesn't it work??

    Why all the black boxes on portrait view.....Why does the cover show on landscape view but when you get to it..it disappears, then shows again when you scroll past it.

    I've determined it's IT8. Anyway to force the IPT to use IT7?
     
  2. 840quadra Moderator

    840quadra

    Staff Member

    Joined:
    Feb 1, 2005
    Location:
    Twin Cities Minnesota
    #2
    You are asking lots of nebulas questions in your post, and what makes this post official? Are you having issues with artwork on both iTunes and the Touch's OS, or just one? I assume you are talking about the Touch since you mentioned landscape view, but I just want to make sure.

    What was the source of the Artwork? Are these songs form ITMS, or did you import your own artwork onto songs for your library? Also, when viewing the "get info" for your songs, does it show artwork in that information?

    [​IMG]
     
  3. Gix1k thread starter macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
    #3
    It's official because there are too many threads on this subject with 5 to 10 replies, but no one with a real answer that's a fix.

    No, these songs are from my PC..mp3s....All .jpg files...tried .png...no good. Below are the files I attach to my 1st gen IPT on IT7 by highlighting all songs, right clicking, get info and dragging that image to the box....works like a charm on that IPT...this 2nd gen....no dice
     

    Attached Files:

  4. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #4
    Check a song on your ipod that doesn't display the artwork and then click get info on that specific song (not the album as a whole) and tell us if the artwork is showing under the artwork tab under more info. If the artwork isn't tagged to each individual song then it won't display on your ipod when you are actually listening to the music.
     
  5. 840quadra Moderator

    840quadra

    Staff Member

    Joined:
    Feb 1, 2005
    Location:
    Twin Cities Minnesota
    #5
    And one more thread with an initial post with vague dicriptions makes this thread offical? :confused: ;)

    Anyway,
    I agree with this post. That is going to be part of how others can help diagnose your issue. Depending on how album art is added to a song, it may or may not appear correctly. I do not believe that you can add art to multiple songs like describe, and I have never got it to work myself. I believe you have to drag the artwork to each song individually.

    Otherwise, this meathod will usually work.

    [​IMG]
     
  6. mrpalmer420 macrumors regular

    mrpalmer420

    Joined:
    Jan 15, 2008
    #6
    As much as i don't like that the OP called this the official thread i have the same issue but with my first gen touch.

    Even the music purchased from itunes. For example when horizontal Weezer the Blue album shows the right artwork but when put Verticle it changes to Korn.

    IF its there why does it switch.

    I really do not want to reset my Touch as it takes forever to get the music/apps/photos/movies back on.
     
  7. -Dark Angel- macrumors 6502

    Joined:
    Nov 13, 2007
    #7
    iTunes 8 works great for me with the album art and coverflow, no blank spaces. Same goes for iPod touch 2nd gen 32GB model. All my album art shows great. I don't do mass sync, I just manage music manually and just drag over items one album at a time. I find if I do batch albums they tend to have blank artwork for some of my albums.
     
  8. Gix1k thread starter macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
    #8

    Dude, listen....regardless of what the thread name is or rename it what you want...This is a serious issue. There are several threads on this and I really want to fix this issue on my IPT...This device is 2 weeks old and it started blacking my artwork from day one. A restore I don't see correcting this. I am doing the exact same thing on this iPod that I am doing on my other iPod, which works, so it's either this ipod(2nd gen) that's a problem or IT8. I'm going with IT8 because I hooked my 1st gen up my my PC with IT8 and it synced and wouldn't you know I ended up with blacked albums. I had to take to other PC that had IT7 and was able to fix it. I refuse to use my 1st gen on IT8.

    Notice arrow album on this view...
    [​IMG]

    This is the arrow album on this view

    [​IMG]
     
  9. 840quadra Moderator

    840quadra

    Staff Member

    Joined:
    Feb 1, 2005
    Location:
    Twin Cities Minnesota
    #9
    Well I (and a few other posters) are taking your issue seriously. Just not the thread title ;) .

    Can you please answer the question / comment posted by mrpalmer420?

    I can't duplicate the issue on my 8GB iPod touch G2 using the images you attached. They work in coverflow, and in any other mode that lets you see album art on the Touch. The only thing I can think of, is the possibility that the ID3 tags or otherwise on your songs are somehow corrupt.

    Have you tried those images on fresh MP3 files and been able to duplicate the issue?

    [​IMG]
     
  10. Gix1k thread starter macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
    #10
    Here is my procedure, respectively. I download album that's in a winrar file. I open winrar, extract folder that is named with whatever CD I just downloaded.. In that folder are all .mp3 files for that CD. I connect my iPod..iTunes opens, I click music and it displays the content on the device. I pull up the album folder I just extracted and drag the however many .mp3 files to my itunes...It then adds to my device. Once they are on there. I open firefox...go to amazon.com, search the album and save the album cover to a folder on my desktop called "Art". I then go to iTunes, click the first song of the album...hold shift then click the last song. This highlights all the songs of the album....I right-click in the highlighted area and select get info....That displays a place where cover goes. I open m "art" folder and drag the image to that box...It displays it in there with a check to the left of the box....I hit OK and it starts this process..I assume writing the image to the files. Once it is done...I pick up the ipod and tap music and then albums and scroll..There lies a black box for that album...in portrait view..I turn landscape and scroll...I can see the album if it next...I scroll to it....cover gone..I scroll past it..cover shows as the one before the one I am on. Ironically, several people at my job have the 2nd gen and have this same issue pretty much...The problems differs in minor ways like the image I posted....it shows all the time in landscape, but never in portrait.

    Also, I do not see a question by mrpalmer420...Just a statement about his own artwork problem.....Post #6
     
  11. txhockey9404 macrumors 6502a

    Joined:
    Feb 25, 2008
    #11
    Try using StuffitExpander if you are on a Mac, or something similar for PC. Just try to unpack it with a different program. Then, delete the old files FIRST and then add the new ones with album artwork. Make sure that your artwork is in .png format, as this may also clear the problem. If this does not work, delete the Album Artwork folder in iTunes in My Music (PC) Music (Mac). Then, get album artwork in iTunes and restore your iPod. If this doesn't work, I'm out of ideas. I had this problem on a 1st Gen with iTunes 7 and 8, and this procedure fixed it for 8. 2 restores fixed it for 7.(Don't know why I needed 2, but that fixed it)
     
  12. Gix1k thread starter macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
    #12
    The thought of a restore kinda feels like the thought of being kicked in the balls.....i just don't know why someone would wanna do that to me.
     
  13. Ivan P macrumors 68030

    Ivan P

    Joined:
    Jan 17, 2008
    Location:
    Home
    #13
    Yeah, I had the same problem in iTunes 7 with a 1st gen touch back in January. It most certainly is not restricted to iTunes 8.
     
  14. 840quadra Moderator

    840quadra

    Staff Member

    Joined:
    Feb 1, 2005
    Location:
    Twin Cities Minnesota
    #14
    Oops. I mentioned the wrong poster, I meant to point to jmann4489's post.

    The method you outline "should" work fine. I still think the issue is with the ID3 tags on your songs. I haven't ever actually used that exact method as I always individually drag artwork to each individual track. I think I got into this habit because when the iPod photo first came out, multiple "get info" was really primitive in iTunes 4.7 (?).

    [​IMG]
     
  15. mrpalmer420 macrumors regular

    mrpalmer420

    Joined:
    Jan 15, 2008
    #15
    Yeah it was my own problem.

    Can anyone figure out why itunes itself is screwing stuff up that was purchased through the itunes store?
     

Share This Page