Official MySQL package doesn't automatically startup server

Discussion in 'Web Design and Development' started by Saliwa, Apr 19, 2008.

  1. Saliwa macrumors member

    Joined:
    Apr 7, 2008
    #1
    I have installed the official MySQL package on my PowerPC Mac with Tiger, althought I have check in the preference pane the "automatically start server", it doesn't, I need to start it manually.

    Has anyone else experienced this problem?
     
  2. SpineyNorman macrumors newbie

    Joined:
    Aug 4, 2007
    #2
    I had the same problem you describe when I installed MySQL on Tiger. When I looked it up, it turned out to be a common and known issue but not one which anyone seemed to be doing very much about.
    I have since updated from Tiger to Leopard but haven't ever had much use for MySQL on my own computer so never bothered trying out the latest install of that. I thought I'd try installing it now anyway just to see if the problem had been fixed.
    In the x86_64 dmg download, the problem still existed but I found the following link after having a look around the error report page. The linked file fixes the problem in Leopard:

    ftp://ftp.mysql.com/pub/mysql/download/gui-tools/MySQL.prefPane-leopardfix.zip

    This link also has an explanation of a fix which apparently works in Leopard though I haven't tried it:

    http://angry-fly.com/index.cfm/2008/1/30/Getting-MySQL-Preference-Pane-To-Work-In-Leopard

    I'm not sure if either of these would work in Tiger or even if you'd want to risk trying but I posted them here so that anyone using Leopard might see them and appreciate the info.

    Basically, I haven't solved your problem since you're running Tiger but I hope you might find it reassuring to know that it seems to be a pretty normal thing to happen! :)
     
  3. macsig macrumors regular

    Joined:
    Oct 27, 2006
    Location:
    Marina del Rey, CA
    #3
    Thank you so much, the new prefPane works just fine: finally I don't have to start the server manually anymore.


    Have a nice day :):):)
     

Share This Page