Offline Playback of Apple Music files.

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Stuey3D, Jul 24, 2015.

  1. Stuey3D macrumors regular

    Stuey3D

    Joined:
    Jul 8, 2014
    Location:
    Northamptonshire, United Kingdom
    #1
    Not sure if this is intended behaviour as some sort of DRM thing or a bug, however any songs I have downloaded for Offline Playback from Apple Music service need an internet connection to play.

    Example

    iPhone has dropped signal and I attempt to play an Apple Music song it will not start to play until signal is back, however once its got a signal it will play as normal from then on even when put into Airplane mode and other songs play as normal.

    If you try to start a song in Airplane mode it throws up a message saying Apple Music songs can't be played, however if you turn off Airplane mode and start to play songs and then turn Airplane mode back on then the rest will play as normal.

    I think this is just a bug, or rather I HOPE this is just a bug as this could be a problem with people going off the grid for a while for whatever reason (foreign trip with no data roaming, trip to rural area with no signal etc)

    Also this ONLY effects Apple Music downloads, your existing music downloaded for offline playback play as normal regardless of data connection.

    Anyone else experience this issue?
     
  2. JakeT85 macrumors regular

    JakeT85

    Joined:
    Jan 19, 2012
    #2
    Mine has been doing this as well, wasn't like this in last beta so think it's a bug.
     
  3. Stuey3D thread starter macrumors regular

    Stuey3D

    Joined:
    Jul 8, 2014
    Location:
    Northamptonshire, United Kingdom
    #3
    Its been like this since Beta 3 for me, can't count Beta 2 as nothing played offline lol.

    Bug report sent to apple already so hope it gets picked up soon.
     
  4. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #4
    I just tested three full albums that I downloaded for offline from Apple Music and they played just fine in airplane mode. Not sure what could be causing them to not play for you.
     
  5. Stuey3D thread starter macrumors regular

    Stuey3D

    Joined:
    Jul 8, 2014
    Location:
    Northamptonshire, United Kingdom
    #5
    Reboot your phone turn on airplane mode and then open the music app and attempt to play the files, it seems to need an initial network connection to authorise them or something.
     
  6. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #6
    My music app was fully closed and never launched in about a day on my first test.

    I tested your reboot thing and they all still played. (Even tried different albums that were downloaded for offline from the first test)

    If you've downloaded a full album can you screen shot the screen for that album (tapped into the album so it shows just the album and track list)
     
  7. Stuey3D thread starter macrumors regular

    Stuey3D

    Joined:
    Jul 8, 2014
    Location:
    Northamptonshire, United Kingdom
    #7
    Hmm dunno then, I can replicate it every time no problem. I wonder what you are doing differently then as me and JakeT85 seem to suffer the same issue so not a problem with just me.
     
  8. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #8
    Can you take a screen shot of an album you've downloaded for offline for me? (The view of just the single album and track list)
     
  9. Stuey3D thread starter macrumors regular

    Stuey3D

    Joined:
    Jul 8, 2014
    Location:
    Northamptonshire, United Kingdom
    #9
    All apart from Guardians of the Galaxy are Apple Music, Guardians of the Galaxy was purchased as not available on Apple Music.
     

    Attached Files:

  10. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #10
    Sorry I mean this view (see image)
    Inside one of the albums you've downloaded and not playing.
     

    Attached Files:

  11. Stuey3D thread starter macrumors regular

    Stuey3D

    Joined:
    Jul 8, 2014
    Location:
    Northamptonshire, United Kingdom
    #11
    Whole album is available offline, however I originally started with the song "Bleed the Freak" so that's why it's the only one with an offline icon even though all of them are available offline.
     

    Attached Files:

  12. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #12
    Yeah. I wanted to just double check if you had the downloaded icon on the top right corner of the artwork. (Which you do)

    Very strange indeed. I rebooted twice more and turning on airplane. All three times (four if you include my original test) still play everything just fine.

    Fully closing the app in the app switcher, rebooting, turning on airplane, launching music and then picking an album I've DL'd from Apple Music.
     
  13. Stuey3D thread starter macrumors regular

    Stuey3D

    Joined:
    Jul 8, 2014
    Location:
    Northamptonshire, United Kingdom
    #13
    Try this, close all apps, reboot iPhone by holding the home and power buttons together, wait for iPhone to get signal and then turn on Airplane mode, open music app and then try to play an Apple Music download.

    Just replicated the problem perfectly.
     
  14. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #15
    I've tried every which way. Exactly how you mentioned. I even did airplane mode before the reboot so it would still be in airplane after and no chance of getting signal and still plays. I've done letting it get signal like you mention, still plays. No matter what I do I have no issues of offline AM music playing.

    It's very strange you can't. :/
     
  15. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #16
    Images below are showing the album was downloaded off AM and playing (icon on the artwork top right corner and not on the songs) and second image in the full screen player.
     

    Attached Files:

  16. Stuey3D thread starter macrumors regular

    Stuey3D

    Joined:
    Jul 8, 2014
    Location:
    Northamptonshire, United Kingdom
    #17
    Well I'm stumped then as to why some of us are having this issue and others are not. It's a weird one.
     
  17. Stuey3D thread starter macrumors regular

    Stuey3D

    Joined:
    Jul 8, 2014
    Location:
    Northamptonshire, United Kingdom
    #18
    For the record though I am running a clean install and set up as new from iOS 9 beta3 onwards so I wonder if that may have something to do with it, I highly doubt it but it could maybe.
     
  18. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #19
    It's been years since I've done a clean install. I only ever use OTA and the last time I did fresh was at least some point in iOS 6. (So OTA all through iOS 7, 8 ,8.3+8.4 betas, 8.4 release, iOS 9 PB1 and DP 4)
     
  19. Stuey3D thread starter macrumors regular

    Stuey3D

    Joined:
    Jul 8, 2014
    Location:
    Northamptonshire, United Kingdom
    #20
    Up until I did a clean install with beta 3 my backup went all the way back to iPhone OS 1.1 on the original iPhone which I had jailbroken to run in the UK (American iPhone) it's served various incarnations of the iPhone and iOS updates so it was about time that I did a clean install, and by god it was worth it so much faster and just less buggy over all.
     
  20. AJT-au macrumors member

    AJT-au

    Joined:
    Jul 26, 2014
    Location:
    Adelaide, Australia
    #21
    I had the same problem but I closed music, turned on airplane mode then rebooted with home and power buttons and now I can play all my music with airplane mode on
     
  21. Stuey3D thread starter macrumors regular

    Stuey3D

    Joined:
    Jul 8, 2014
    Location:
    Northamptonshire, United Kingdom
    #22
    Ahh so there is definitely something wrong with it then.

    To be honest it's not Airplane mode that I first noticed this, it was when my phone dropped to a GPRS connection and I wanted to play the files whilst driving home, that was rather frustrating.
     
  22. Pug72 macrumors 6502a

    Pug72

    Joined:
    Mar 18, 2012
    Location:
    England
    #23
    Same happened to me on a trip Thursday.

    Music stopped on a shuffled playlist, I thought it was down to a bug whilst using sat nav....but this makes more sense.
     
  23. Stuey3D thread starter macrumors regular

    Stuey3D

    Joined:
    Jul 8, 2014
    Location:
    Northamptonshire, United Kingdom
    #24
    Yeah I first noticed this when my phone dropped onto a donkey slow GPRS signal and it just hung whilst trying to play offline Apple Music files as if it was trying to stream them even though they were saved. Eventually it either just gives up and stops all together, or it will suddenly start to play one of my normal non Apple Music songs.
     
  24. stusgt67 macrumors regular

    stusgt67

    Joined:
    Jul 10, 2015
    Location:
    United Kingdom
    #25
    Hmm, I'm thinking this is why sometimes the Music App for me skips a song when walking to work on iOS 8.4. Sounds like a bug =/
     

Share This Page