Oh **** - 2012 Mac mini just fell !!!!

Discussion in 'Mac mini' started by takiv, Apr 15, 2013.

  1. takiv, Apr 15, 2013
    Last edited by a moderator: Apr 15, 2013

    takiv macrumors member

    Joined:
    Jan 5, 2013
    Location:
    Moonville, SC
    #1
    Edit......... The mini landed on power cord and cut cord almost in half, thats what caused the sparks/burn marks. Now I wonder if I need anything other than a new cord ?

    My 5 month old 2012 Mac mini just fell, landed on the corner with pwer supply, spark, and there is scorch mark, burn mark on case. I figure my power supply is probably shot at the least. Will Applecare cover this ? What else might be bad ? Should I open up the unit , or just take it to store ?
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Applecare does not cover damage, only defects.

    Bummers though :(
     
  3. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #3
    I would not open it, I'd take it straight to Apple. AppleCare won't cover user damage, but you don't want to make the damage worse & repair bill higher by monkeying with it yourself. If you have it repaired by Apple, the remainder of your AppleCare will still be valid - if you have it fixed elsewhere then later need service, AppleCare may refuse on the basis of unauthorized repairs.
     
  4. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #4
    Attach a new Euro plug Cable (Yes that's what they are called) and it will probably work again, I think the short was almost sure to be in the cable, how did you otherwise end up with the scorch mark on the outside.
     
  5. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #5
    One other thing, perhaps goes without saying.

    Next time, consider putting the computer in a more secure place... ?
     
  6. takiv, Apr 15, 2013
    Last edited: Apr 15, 2013

    takiv thread starter macrumors member

    Joined:
    Jan 5, 2013
    Location:
    Moonville, SC
    #6
    I just plugged new cable in, unit started, I got the start sound, fan spins, but I'm not getting any video out on my mdp to dvi , powered off mini, got out my hdmi to dvi adapter and I do get video out there. This is my first MAC, how do I trouble shoot diplay port issue ? Other than trying a different mdp adapter which I don't have. I don't see any physical damage to mdp to dvi adapter , is there some voltage readings between pins I should look for ?

    I feel better that my mini is alive, sparks freaked me out.

    justperry, very true, in my freaking out didn't think that far, Fishrrman yes without saying, this is a temporary setup as my home office is being renovated. I had it in a vertical stand, I'll leave it flat on table until I'm back in office.
     
  7. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #7
    Try with a another Mdp port to DVI Cable, that is, if you have one:p
    Might be the Cable.
    But, you could also reset both PRAM/NVRAM and SMC, might solve the problem.

    Glad the Mini startup though, I have one myself, great machines.
     
  8. mus0r macrumors regular

    Joined:
    Mar 27, 2005
    #8
    This doesn't help you any, but you just talked me out of buying one of those stands.
     
  9. takiv, Apr 15, 2013
    Last edited: Apr 15, 2013

    takiv thread starter macrumors member

    Joined:
    Jan 5, 2013
    Location:
    Moonville, SC
    #9
    Reset SMC, PRAM/NVRAM, still nothing through MDP-DVI adapter. Guess I'll have to go pickup new adapter, tomorrow on my way to class.
     
  10. Che Castro macrumors 603

    Joined:
    May 21, 2009
  11. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #11
    I'd bring it to Apple before spending any more money on cables. They'll hook it up and should be able to tell you what's wrong.
     
  12. takiv, Apr 15, 2013
    Last edited: Apr 16, 2013

    takiv thread starter macrumors member

    Joined:
    Jan 5, 2013
    Location:
    Moonville, SC
    #12
    Update, picked up new MDP-> DVI adapter, everything works fine now. Lesson learned, when using mini at dining table, keep away from edge and use horizontally.

    This had nothing to do with the stand, just bad placement on my part. Fortunately I was the one to knock it over, and not a house guest.




    I pick up a new cable, if it works I know my original adapter went bad, send it in get it replaced I'm out postage to return. I return new adapter get my money back.

    If new adapter doesn't work, I know I have a problem with mini display port. I call apple care back and see what they will do, I called earlier and they want me to try new mdp->dvi adapter.
    No big deal
     

Share This Page