Oh boy...what did I move? (iTunes library)

Discussion in 'Mac Apps and Mac App Store' started by Pedro Julio, Oct 24, 2011.

  1. Pedro Julio, Oct 24, 2011
    Last edited: Oct 24, 2011

    Pedro Julio macrumors member

    Joined:
    Oct 24, 2011
    Location:
    Sometimes NC, Sometimes PA
    #1
    Hi. Long time lurker, first time poster.

    So, I've had my iTunes and iPhoto libraries on an external drive for a while now. System has worked fine for me thus far. However, yesterday saw a confluence of weird circumstances, and now I am not sure which of them is causing my issue.

    First: I recently had my logic board replaced in my 2008 MBP. Because I was at my 5 computer authorization limit already, I had to deauthorize all and then reauthorize my newly repaired machine.

    Second: I opened iTunes and dropped a couple of movies into it, and synced my iPad. HOWEVER...afterwards I discovered that my external drive was not mounted when I did that. So those movies went somewhere onto my internal drive instead.

    So, I quit iTunes, plugged in the external drive, and then restarted iTunes while holding option. I chose what had been the appropriate iTunes folder (iTunes Media) from the external drive, but now I get the error message that says there is no Library file.

    I'm typically pretty good at trouble-shooting my own problems, but iTunes gets me every time. What have these operations done, and can I undo them?

    Thanks in advance

    PJ

    EDIT: Yeah, I dug around in the forum for a day before posting. There's no lack of iTunes library related threads.
     
  2. Panch0 macrumors 6502a

    Joined:
    Feb 23, 2010
    Location:
    Virginia
    #2
    The library file is not necessarily in the Media location. The library is a sort of database that lists your media and contains the path that lets iTunes find the media files. You can actually have your media files spread across many different physical locations.

    When you opened iTunes to the default library, did it include all of your items (even if it show explanation points next to all of them as "not found")? If so, you could just attach your external drive then open the default library and everything should be back in place.

    If not, try looking for the library one level up from iTunes Media on the external drive.
     
  3. Pedro Julio thread starter macrumors member

    Joined:
    Oct 24, 2011
    Location:
    Sometimes NC, Sometimes PA
    #3
    Yeah, the default library did open up and show all of my content, but there were a few items with exclamation points.

    I'll try plugging in the external drive and starting iTunes up. Maybe the issue will solve itself that way. Man, I hope that does it.

    As for the two new movies, if the fix works I could probably just delete them from iTunes, and then put them back in again with the external drive plugged in.
     
  4. Pedro Julio thread starter macrumors member

    Joined:
    Oct 24, 2011
    Location:
    Sometimes NC, Sometimes PA
    #4
    This turned out to be a bit of a "duh" moment.

    I had opened iTunes without having my external drive connected. I didn't realize it wasn't connected because all of the content appeared to be in place. I then dropped those two new movies into iTunes like I normally would. That caused the system to recreate all of the library organizational files in the iTunes folder on the internal hd. So when I realized my mistake, plugged the external drive in, and tried opening that library, I got the error.

    Solution: Take all of the library organizational files from the internal drive and put them in the iTunes file on the external drive. I wasn't sure that would do it, but it worked. I just had to redefine the paths for the two new movies and I was good to go.
     

Share This Page