Ok. I updated to 10.5.7. Now Im getting errors on build and go.

Discussion in 'iOS Programming' started by jtbullet, May 22, 2009.

  1. jtbullet macrumors member

    Joined:
    Jan 19, 2009
    #1
    I was running a version of the sdk called 2.2.19a? or something like that, and there seems to be a marginally newer version on the devcenter site called 2.2.19 (drop the a).

    In short im trying to work out:
    1) which version of the sdk to be using for 2.2.1 os
    2) should I install the beta os for the ipod touch (my dev device)
    3) should I install the iTunes beta?

    My app is simple, just calling images, with buttons to navigate between them. I dont forsee anything to make it 3.0 incompatible. Suggestions? I kind of need to work this out quick, im leaving for vacation tomorrow with no net access for a week, Im withdrawing already!
     
  2. kainjow Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #2
    I thought I remember reading somewhere that Apple will require all new apps be built with the 3.0 SDK, so you should probably upgrade and stay upgraded if possible.
     
  3. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #3
    Please see this notice from the iPhone Dev Center:

    Important Information About iPhone OS 3.0 Compatibility

    ...especially these parts:

    So, you need to be compatible with OS 3.0 for approval, but until 3.0 is officially out you need to build and submit using 2.x.
     

Share This Page