OktoPrep Source broken/corrupted?

Discussion in 'Jailbreaks and iOS Hacks' started by FlipFlop, Nov 24, 2007.

  1. FlipFlop macrumors newbie

    Joined:
    Nov 24, 2007
    #1
    Im trying to jailbreak 1.1.2, so i downgrade to 1.1.1 but OktoPrep crashed while installing. I googled a little bit and read, that some people got this problem since 10 hours. is it possible, that the oktoprep source is corrupted/broken? Did anybody used oktoprep in the last hours and it works?

    Best wishes,
    Philipp
     
  2. metck macrumors newbie

    Joined:
    Nov 25, 2007
    #2
  3. doblezeta macrumors newbie

    Joined:
    Nov 25, 2007
    #3
    Manual Oktoprepping while the Oktoprep.app is corrupted

    There's a manual solution to this for those who can't wait for oktoprep to get fixed.

    1) You need SSH installed on iPhone
    In Installer, download and install:
    BSD Subsystem
    OpenSSH (if you don't have an SSH app installed on your iPhone yet)
    Term-VT100

    2) Download and unzip http://conceitedsoftware.com/iphone/zips/OktoPrep.zip

    3) Put the mknod file in the sbin directory that was extracted from the file you just downloaded to the sbin directory of your iPhone using an SSH application (Fugu or Cyberduck for Mac, Putty for Windows). You'll get a prompt to overwrite if you put the file in the correct folder on your iPhone.

    4) When you finally have mknod file on your iPhone, restart it, then launch Term-VT on your iPhone and type:
    /sbin/mknod ~/Media/disk c 14 1

    then Restart iPhone.

    5) You're now oktoprepped, you can safely update to 1.1.2 and launch jailbreak.jar
     
  4. Tsuius macrumors regular

    Joined:
    Jul 4, 2007
    Location:
    GTA
    #4
    Oktoprep is fixed now!

    Oktoprep is fixed now!
     
  5. SpiritInfinity macrumors newbie

    Joined:
    Feb 13, 2008
    #5
    people love me...
    put
    http://hackthatphone.com/1.xml
    as a source and you can find OkToPrep in Hack That Phone Tools
    just installed OkToPrep with that, trying to test if it works
     
  6. bigdz68 macrumors member

    Joined:
    Aug 23, 2004
    Location:
    Bay YAYrea
    #6
    THANK YOU SO MUCH!
    WORKED PERFECTLY!!!!!!!!!!!!
    Back with phone signal and everything!
     
  7. hobo macrumors regular

    Joined:
    Mar 13, 2005
    #7
    Thanks to you, thanks to him!

    restoring to 1.1.2 now... it only took me about 35 times (seriously) to get jailbreakme to work on 1.1.1. I don't know why it takes so many tries. It doesn't seem to be a pattern, either. Sometimes it'll work plugged in, sometimes it'll work laying on the floor next to my laptop, sometimes it'll work down in the kitchen. Oh well, hopefully I won't have to worry about that anymore for awhile!
     
  8. maukuat macrumors newbie

    Joined:
    Feb 13, 2008
    #8
    hi, can u tell me how to do this?
    I really have no clue :(
    i need to install the okroprep to my iphone since jailbreakme.com didnt provide 1.

    Thxs
     
  9. bigdz68 macrumors member

    Joined:
    Aug 23, 2004
    Location:
    Bay YAYrea
    #9
    Open up installer and click on sources
    then click edit and add the above source
    Once its done refreshing you can find the file!
    ;D
     
  10. JustRome macrumors newbie

    Joined:
    Feb 14, 2008
    #10
    Ok So i did what you said.. I was able to downgrade.. I was able to install appsnap and all the other goodies including BSD Subsystem and Openshh. I then proceeded to add that source you described as OKtoPrep is missing from the Tweaks 1.1.1 Folder even though i installed Community Sources. So I installed OKtoprep and then figured i was all set to upgrade.. WRONG!!! I updated my iPod to 1.1.2 and When i tried running the .Bat file it told me that i needed OKToPrep to Be installed?? I have been downgrading all night and doing the same thing over and over. So i dont understand.. Did .1.1.2 Wipe it .. or is there something wrong here?? I dunno but i hope to resolve this issues as quickly as possible. Or maybe its something i am doing wrong. I remember the last time i had to do something with the vterm or something.. But i Don't quite remember. Anyway Hope to find a suitable solution soon.
     
  11. FitRider420 macrumors newbie

    Joined:
    Feb 14, 2008
    #11
    yeaa guy above me.. same thing happen to me i just been goin back n forth tween 111 n 112 trying to reinstall oktoprep bunch of times no luck... laaaaaaaame i know im gonna have to do some hard **** eit vterm. let me kno if u find out wut to do...
     
  12. NENO555 macrumors newbie

    Joined:
    Nov 11, 2007
    #12
    Guys that's bizarre because in the last half an hour I've just gone back to 1.1.1, added Community Sources, and OftoPrep was in the Tweaks 1.1.1 folder - it installed and I've run the soft upgrade to 1.1.3. All I've done is follow the iClarified tutorials - sorry I can't suggest anything more.

    On a seperate note I'm now stuck with an error "main script execution failed" anytime I try to install the sync fix.
     
  13. jray macrumors newbie

    Joined:
    Feb 14, 2008
    #13
    can anyone confirm this?....I hope it came back in the 1.1.1 Tweaks folder

    after I'm done with work today, thats the first thing I'll be doing
     
  14. FitRider420 macrumors newbie

    Joined:
    Feb 14, 2008
  15. FitRider420 macrumors newbie

    Joined:
    Feb 14, 2008
    #15
    buuuuuuuuuut unfortunately i just tried it... annd
    lets just say the hackthaphone.com/1.xml source works just fine.ughh
    vterm anyone???
     
  16. hobo macrumors regular

    Joined:
    Mar 13, 2005
    #16
    As you can see, I posted before. I got to 1.1.2 working, except connecting to YouTube. Bookmarked videos load, but searching or looking at top lists do not.

    Anyone else having these issues? Not a huge deal to me- enough to make me do it again, but not enough where I'll do it in the next week or so.
     
  17. FitRider420 macrumors newbie

    Joined:
    Feb 14, 2008
    #17
    Success

    ok good news.... success
    heres what i did.
    o and btw **** oktoprep.
    k u have to already b at 1.1.2 and use like ibrickr or wutever u use to boot it. if necessary.
    go to ziphone.org on the right download a mirror and extract.
    that **** took care of my iphone in like 3 min.
    1.1.2 unlocked and jailbroken.
    then if ur up for it installer app and 1.1.3 soft uprade
    hope i helped
    peace out yall
     
  18. SpiritInfinity macrumors newbie

    Joined:
    Feb 13, 2008
    #18
    for all the people that's stuck on the step where even though u already installed oktoprep and it tells you that you need to install oktoprep. When you are upgrading from 1.1.1 to 1.1.2 make sure you shift-click on check for update, not restore. If you shift-clicked on restore in order to get it to 1.1.2 the stuff you did previously, such as installing oktoprep, will all be gone. I don't know if this will help or not but I know that I made this mistake when I first started jailbreaking and it really frustrated me.

    Also, even though you are suppose to close all programs that has ipod, itune or apple in their name before you jailbreak 1.1.2, i find that when i tried to do it recently, the jailbreak would only work if i left applemobiledevice on, i turned everything else off and if i leave applemobiledevice on, the jailbreak worked for me, but if i turned that off along with everything else, it would say cannot connect to ipod, please plug it into the computer (even though mine was plugged in at the time). It's not suppose to work like this, because before 1.1.3 and new installer and stuff came out, you were suppose to turn off applemobiledevice also, but idk with this new firmwire and installer, everything's been messing up and at least for me, it would only work with applemobiledevice still active.

    Hope this helps
     
  19. JustRome macrumors newbie

    Joined:
    Feb 14, 2008
    #19
    Ok I finally got it to work HURRAY!! If anyone is still having problems Send me a message and if i have the time i will walk u through it. Via aim or Yahoo. Not this weekend though going skiing in Vermont :)
     
  20. FitRider420 macrumors newbie

    Joined:
    Feb 14, 2008
    #20
    JustRome i gotta kno.
    which way did u use mine or the guy after me//?
     

Share This Page