Old 4.0 iPhone 4.... Can I update it?

Discussion in 'Jailbreaks and iOS Hacks' started by Daneel7, Jul 19, 2011.

  1. Daneel7 macrumors newbie

    Joined:
    Jul 19, 2011
    #1
    Hey,

    This is my first post here so Heyyy :)

    I recently lost my iPhone and am now using an old one that was Jailbroken using Jailbreakme about a year ago and is still on 4.0. Today I went to upgrade it to 4.3.3 and discovered that Apple are no longer signing that firmware.

    Is there anyway I can upgrade the firmware to anything more recent and to a jailbreakable state? Mainly for the battery life!

    I have read about SHSH and blops backups which I don't have, and from what I have read today, it doesn't sound like 4.3.4 with be untethered at all.

    I fear a 'Nope' will be the answer, but is there anyway to update it?

    Thank you

    Andy
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
  3. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #3
    If it was jailbroken . Ur blobs MIGHT Be saved on Cydia servers.. Do this download tiny umbrella . And try fetching the blobs. Also u hav an unlockable baseband which u wud want to keep. Use custom firmware to upgrade if u have blobs on Cydia . Does Cydia show numbers on its home page in green color?
     
  4. Daneel7 thread starter macrumors newbie

    Joined:
    Jul 19, 2011
    #4
    Hey,

    Thank you both for the responses :)

    @Abs_p On the Cydia homepage there is "SHSH: iOS 4.1, 4.2.1, 4.2b3, 4.3.3" in green at the top of the page. Is that what your refering to?

    Thanks again
     
  5. awadeee macrumors 68020

    awadeee

    Joined:
    Jan 21, 2011
    Location:
    Viper City
    #5
    Leave it on 4.0 with the unlockable baseband until Pwnagetool/Sn0wbreeze are updated to untether 4.3.4 and then update and preserve the baseband. :) Or, if you have SHSH, update to a custom-made 4.3.3. There is no 4.3.4 untether anywhere right now.
     
  6. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #6
    Yeah. U have blobs saved.. :) u r in luck. I would advice u to upgrade to 4.2.1 .. I have noticed it works better then 4.3.3.. Are u on a locked phone? Or a factory unlocked one?
     
  7. Daneel7 thread starter macrumors newbie

    Joined:
    Jul 19, 2011
    #7
    I have downloaded TinyUmbrella and it has "All saved SHSHs" then a list of the firmwares including 4.2.1 with a number after them. I assume I have to use a program to create a custom firmware with the number in it?

    Thank you for your help :)
     
  8. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #8
    Use sn0wbreeze 2.2 for 4.2.1 :)
    Download 4.2.1 ipsw from google for iPhone 4..,if need help pm me. M off to bed. Will get back to u In the morning :)
     
  9. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #9
    PwnageTool (Mac) or Snowbreeze (Windows) will get you to iOS 4.2.1

    www.iclarified.com has perfect guides on how to do this.
     
  10. Daneel7 thread starter macrumors newbie

    Joined:
    Jul 19, 2011
    #10
    Hey,

    Trying to make the Custom IPSW on sn0wbreeze, but keep getting an error saying it has failed because "" is not and integar :confused:

    Downloading another Restore file now.
     
  11. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #11
    Never used snowbreeze. No clue on that error.
     
  12. Daneel7 thread starter macrumors newbie

    Joined:
    Jul 19, 2011
    #12
    After some looking around it appears 2.2.1 is the one. 2.2 goes up to 4.2 and 2.2.1 is for 4.2.1.

    I have the custom IPSW now to install it :)
     
  13. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #13
    Before you restore with the custom firmware, having TinyUmbrella open with TSS Server running.
     
  14. awadeee macrumors 68020

    awadeee

    Joined:
    Jan 21, 2011
    Location:
    Viper City
    #14
    I use Sn0wbreeze quite a bit for phones that I buy/sell and I've never once run into that error.
     
  15. Daneel7 thread starter macrumors newbie

    Joined:
    Jul 19, 2011
    #15
    I have it working now on 4.2.1 :)

    I used sn0wbreeze 2.2.1 and after a hurried first go (when I didn't uncheck the Hactivaction, and was left with 4.2.1 working fine but no network lol) I redone it now and all is working fine :)

    Thank you to every one for your help :)
     

Share This Page