Old Dell 2470WFP & new iMac NEW issues

Discussion in 'Mac Accessories' started by icharry, Mar 18, 2012.

  1. icharry macrumors newbie

    Joined:
    Jun 23, 2009
    #1
    Ok I have a 2006 Dell UltraSharp 2407WFP that has been working FINE on my mid-2010 iMac running OSX 10.6.8. It is connected DVI to Mini display.

    It has basically bee working totally fine till last week when all of a sudden the screen on the iMac would go blue for about 2-6 seconds then come back. no work lost or anything. Then later that week it started going blue and when it cam back it was at 1920 X 1200 resolution - I would try to change it back to 2560 X 1440 - but it would not actually change even though the monitor pref saud it was at that setting AND below that it would say Usable Resolution 1920 X 1200. All this was happening with the Dell turned off.

    Took it to the mac store - they said all was fine. The issue was the dell monitor drawing just enough power from the minidisplay port to confuse the iMac.

    Wondering WHY now after 1.5 years of being OK? Wondering if anyone has a fix or a thought? The apple genius seems to be correct as I hve the dell not plugged into mini display and I have not had the problem since.

    Thanks
     
  2. SR45, Mar 18, 2012
    Last edited: Mar 18, 2012

    SR45 macrumors 65832

    SR45

    Joined:
    Aug 17, 2011
    Location:
    Florida
    #2
    I'm a little confused. Your monitors native resolution is 1920 X 1200, not 2460x1440, so why are you trying to push it to this resolution where it is not really suppose to be ??

    I think its your graphics card that is giving you the issue. Not 100%. Others will have to weigh in on this one. Sorry.
     
  3. icharry thread starter macrumors newbie

    Joined:
    Jun 23, 2009
    #3
    The 2560 X 1440 is on the iMac. that is the screen that keep resetting its resolution to the lower setting even if the Dell is turned off.
     
  4. gwerhart0800 macrumors 6502

    Joined:
    Mar 15, 2008
    Location:
    Loveland, CO
    #4
    Can you try out a different video cable between the Mac and the Dell display? Just to see if there is a connection issue.

    I have a variation on your issue with an ACER display (AL2216W) that occurs every time the laptop and display go to sleep. When the laptop wakes up, the displays bounces all around flashing blue with windows shifting between the laptop display and the ACER until they finally settle down. Sometimes, all my windows end up on the laptop display, sometimes they all end up on the ACER, and sometimes, they swap displays with no rhyme or reason. In my case, I think the ACER display does not properly negotiate the connection with the laptop. (I also can't boot the Mac with the ACER attached or I end up with no desktop on either display.)
     

Share This Page