Old G4 933 Power PC won't shut down

Discussion in 'Mac Basics and Help' started by planetarmor, Jul 20, 2008.

  1. planetarmor macrumors newbie

    Joined:
    Jul 19, 2008
    #1
    When I try to shut down - it just restarts,... have to do a hard shut down.
    Also cannot reset PRAM- or start from disc pushing down on C. The computer just ignores the commands and starts as usual. This thing shuts down due to over heating often as well. I 'm thinking of getting it serviced but is it worth it? It's an old friend and would like to keep it around.:eek:
     
  2. macmikey2 macrumors regular

    macmikey2

    Joined:
    Jul 6, 2008
    Location:
    West Chester, PA
    #2
    A couple things to look for...

    Try these to narrow down the problem.
    make sure that keyboard / mouse are unplugged and plug Mac in. Does it startup by itself?

    Check the power button and make sure it is not crooked or pushed in

    Open door and remove backup battery. Plug in. Does it power on?

    Try with another keyboard only, zap PRAM. If you can, also do Open Firmware reset (command-option O-F), then type reset-nvram and hit return, then type reset-all and hit return. it will restart

    Hope these help. BTW... backup batteries are available at Radio Shack.

    Mike
     
  3. Tonto Yoder, Feb 28, 2011
    Last edited: Feb 28, 2011

    Tonto Yoder macrumors newbie

    Joined:
    Sep 20, 2008
    #3
    This happens to me every once in a while too (and I generally forget what worked to fix the problem in the interim).
    Happened again over the weekend--hit "Shut Down" but the computer eventually would restart itself after taking an overlong time to shut down.
    Somehow it's OK now, but I'm unsure exactly what the fix was?
    I reset the PRAM and tried minimizing the peripherals plugged into the computer---turned off one external hard drive, unplugged the keyboard from a USB hub and put it in one of the Mac's original USB slots, unplugged an external DVD drive.

    Again, I don't know exactly WHY this worked or what specific step was the key.
    Probably is a good idea to troubleshoot by minimizing peripherals right?
    Hope this helps someone down the line.

    BTW, I have another symptom---if I try to put the computer to sleep, when I awaken it, I get the "Device Removal" stop sign warning (as if I had ripped an Ipod connection out or an external hard drive out). I suspect there's a glitch with the ext. hard drive where it sometimes loses its connection even though all the cords/ power supplies etc are JUST like they were before.
     

Share This Page