Old iBook reset PMU problem

Discussion in 'PowerPC Macs' started by PhilDT, Oct 7, 2009.

  1. PhilDT macrumors newbie

    Oct 7, 2009
    Hello, Im using a 2002 iBook mainly as a diary and the calendar went into the default 1970 mode, I started it up today and it crashed whilst I was resetting the time and date, - read some forum stuff and reset the PMU, seemed to work as initially it started to reboot and then screen went black after a small sort of chirping sound. The battery and power lead are fine, lots of free memory, any suggestions please
  2. hodgeheg macrumors regular

    Dec 7, 2008
    have you tried resetting the nvram? I forget the key combination for an iBook but if you google you'll find the apple support document.

    Also possible your PRAM battery may need replacing but I don't know how to check for certain.

    Also worth trying booting off Apple Hardware test CD (which depending on your model may be the first os x install disk. Again I forget exactly how but see manual and/or google. That would enable you to test for certain hardware faults. If your PRAM battery has died you nay find you need to do nvram and Pmu resets in order to get booting from cd by holdin down c on startup to actually work.

    I'm sure others will know more that you can try but that's about all I personally can think of. Good luck
  3. PhilDT thread starter macrumors newbie

    Oct 7, 2009
    PMU Problem

    Thanks for the reply, I wondered if the iBook had a separate lithium battery which needs replacing, the same thing happened on my first mac. Ive not read anything about the extra battery on an iBook. If it wont boot up normally how can I boot up from the install disk?
  4. hodgeheg macrumors regular

    Dec 7, 2008
    You may not be able to, but you may. Basically you hold down C immediately after pressing the power button, and keep it held down until it appears to be booting off the CD. Sometimes this doesn't work if your NVRAM is corrupted, in which case an NVRAM reset may fix it (this happened recently on my PowerBook). On the Powerbook this is hold down Command, Alt (option), P and R on boot, but I don't know if the iBook is the same. For some reason, although the Apple support documents didn't say this, for me it only works with right command key. Then after I'd powered off and back on holding down C worked.

    There's also safe mode, and single user mode (see google) that might let you do some things, but I don't know much about these.

Share This Page