Old iPhone3g "waiting for activation

Discussion in 'Jailbreaks and iOS Hacks' started by dave23232, Aug 6, 2010.

  1. dave23232 macrumors newbie

    Joined:
    Aug 6, 2010
    #1
    I have replaced my 3g with the iPhone4. My 3g was JB with pwngtool 4.01 but recently was starting to get slugish (using it as an iPod / internet viewer over WiFi) so I decided to restore it/update to new firmware and rejailbreak it via jailbreakme.com this time. I also wanted to unlock it with the new Ultrasnow for trips to Europe since I'm not sure how easy it is to find a prepaid microSIM to use with the ip4.

    Anyway restore on 3G goes fine, i kept the old original ATT SIM card in it (it is not active anymore but don't think it has to be) I'm not stuck on any emergency screen or anything. All functions are accessible but I have the "Waiting for activation / This may take some time" message on lockscreen everytime I reboot it. It also pops up once and a during other functions.

    Is this normal? Should I be getting this msg? Do I need to keep waiting? I've restored twice so far. Will this message go away if i put an active SIM and if I do does it have to be ATT? (it was locked to ATT BTW) the only other SIM I have is a non US one but doubt I would even get service with that since its a prepaid restricted Europe SIM.

    Thanx

    Edit: I restored with the original SIM. so shouldn't it activate?
     
  2. jfdonohoe macrumors newbie

    Joined:
    Jan 18, 2008
    #2
    I am curious about this as well. I work for an app developer shop and I replaced my G3 with a G4.

    I want to keep my G3 for QAing apps in development on a 3.1.2 version of the iOS. I reset to factory settings by reinstalling a image package "iPhone1,2_3.1.2_7D11_Restore.ipsw".

    I too get the "Waiting for Activation" screen and I am unable to install dev apps on my 3G and I believe its because the phone isnt activated so the dev distribution profile wont work with that phone (the same dist profile worked before I switched phones. The UUID is the same.)

    Will the activation take place eventually or does it need to be linked to an active AT&T account to become activated?
     
  3. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #3
    Makes you wonder if apple made some changes back at base to prevent activation with a non-active SIM? It appears they made some changes for the Phone book SIM so maybe its wider than first thought.
     
  4. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #4
    Same issue as the OP; upgraded to iPhone 4 but forgot to delete all my stuff on my old 3GS before selling it and long story short, ended up doing a complete restore back to 4.0.1 on the 3GS but now it is not activated (since I already upgraded) and need to re-visit jailbreakme.com to make sure it is jailbroken and then re-unlock it. Any ideas?
     
  5. SpaceKitty macrumors 68040

    SpaceKitty

    Joined:
    Nov 9, 2008
    Location:
    Fort Collins Colorado
    #5
    I gave an old 3G iPhone to a friend about a month ago so she could use it as an iPod. I put an old sim card into it and it was running 3.1.3. It too gets the waiting for activation message but sliding to unlock makes it go away until it is rebooted once again.
     
  6. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #6
    I should have made my question more obvious - I understand the message goes away - but if I sell my phone, is there any reason the next buyer will have any problem using it, and will he still get this message on every reboot?

    I'll probably go craigslist, so I don't want someone coming back to me in a few days saying I sold them something that doesn't work.
     
  7. SpaceKitty macrumors 68040

    SpaceKitty

    Joined:
    Nov 9, 2008
    Location:
    Fort Collins Colorado
    #7
    I have no idea. I was replying to the others in this thread letting them know it happens on 3.1.3. as well.
     

Share This Page