Old Mac, New external HD

Discussion in 'Mac Basics and Help' started by studiomarcardia, Feb 24, 2010.

  1. studiomarcardia macrumors newbie

    Joined:
    Feb 24, 2010
    #1
    I've just spent hours on this forum searching for answers. I've tried many things suggested to other mac users that seemingly have the same problem but still I seem to have a non-working external HD. So, here's the story...
    I have a Blue and White G3 that I bought in 1999 and am currently running 10.2.8. It's the powerPC processor, I think cause I know it's not Intel. I could probably upgrade the OS a little, but why at this point? Anyway, I love this computer and yes, I am probably a bit attached. But I've had it for 10 years and have never had a problem...until now. About 8-9 months ago it started running slowly. I figured it was just a problem with memory/space/storage. I used up all the space it had with no concern what so ever. So last week my new external hard drive arrived in the mail, (because now it won't even save a single document). It's a 500 GB WD Elements. Yippee!!!! I installed it, formatted it and have been slowly transferring files to it over the past few days. Today in an effort to free up even more space, I got smart and decided to delete some apps I don't use i.e. dreamweaver, freehand, etc. Afterwards, I restart and suddenly my new HD doesn't show up on the desktop anymore. I go into disk utility and I verify disk, then repair disk, still it's a no show on the desk top. I read more in rumors so I now try to mount the disk...still nothing. I unplug and replug. More nothing.
    This is what happens...
    When verifying I get a message, "Invalid node structure". Also, a separate message appears in a box, something about an unknown disk cannot mount. That happens when trying to repair or on restart.
    So here I am and I'm nowhere near done with any of this process.
    Luckily I didn't erase all the files as I transferred them so I didn't loose much.
    I'm not too techie so if you have some info for me could you talk baby talk please.
    Any ideas, techniques or suggestions are greatly appreciated.

    Thank you in advance for your expertise,
    studiomarcardia
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    It would help to know what you've tried.

    G3, G4, and G5 are PowerPC processors, yes.

    I'm running Tiger on my 500 MHz iBook G3. It's sluggish, but most current apps still support Tiger, so it's still usable. But if you're happy with your current solution, there's no point in upgrading. Jaguar runs faster on there than Tiger would.

    That's probably why it was running slowly.

    I hope you used Macromedia's uninstaller for the purpose. What version of the apps (or Macromedia Studio) are you using?

    Sounds like the volume is damaged. This could be the result of a number of factors, but since it's a new drive, you have to consider the possibility that the drive was borked on arrival.

    Are any of the files you have lost particularly important to you?
     
  3. studiomarcardia thread starter macrumors newbie

    Joined:
    Feb 24, 2010
    #3
    The only thing I really tried was to repair the disk in Disk Utility. Other than that I don't know what else to do. The external hard drive does not show up on my desktop but does show up in the Disk Utility.
    I didn't use Macromedia's uninstaller because I never knew it existed. I had studioX installed. I just dragged it all to the trash and then restarted. Is that bad?
    I haven't lost any important files since I couldn't bring myself to delete them yet. So now I'm thinking about erasing the disk and starting over. Any thoughts? And thank you very much.

    studiomarcardia
     
  4. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #4
    Have you ever given thought to upgrading the version of OS X that you're using?

    10.2.x is probably "too far back".

    I would suggest upgrading to Panther (10.3.x). You can take that all the way to 10.3.9 via Software Update. Granted, 10.3.9 is no longer actively supported by Apple, but is still functional for many uses (I'm using it right now as I type this reply on a 6-year-old PowerMac g4). 10.3.9 is a better version of the OS than anything back in 10.2.x.

    I'm not sure if Tiger (10.4) can run on a g3 (may required a g4 processor). Might be worth looking into.
     
  5. studiomarcardia thread starter macrumors newbie

    Joined:
    Feb 24, 2010
    #5
    Thanks Fishrrman, yes I have thought about upgrading. If I can fix this problem I will again consider upgrading. Otherwise I may just have to buy a new Mac.
     

Share This Page