Old MacBook will not boot

Discussion in 'MacBook' started by bfred123, Jun 27, 2011.

  1. bfred123 macrumors newbie

    Joined:
    Jun 27, 2011
    #1
    I am not sure of the exact model but it is one of the first generation intel MacBooks, circa 2006.

    It worked perfectly up till last week. When I try to boot normally from the internal hard drive, it will not go past the white screen with apple logo and spinning wheel.

    If I try to boot from the original installer DVD it ejects after about 30 seconds.

    I tried connecting to an external HD via firewire and starting up with the option key held down but it only sees the internal HD.

    I tried zapping PRAM, taking battery out, holding power key. Nothing helps.

    I already have a new machine but I was hoping to give this one to my young niece. Is it worth fooling with anymore or should I just give up? Is there somewhere I can donate it to for parts?

    Thanks in advance for any advice.
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #2
    Boot in verbose mode by holding down command-v. What's the text on the screen when it's trying to boot?

    If you see something along the lines of "disk0s2: I/O error" then you probably have a bad hard drive.

    The installer DVD is being ejected either because the disk is bad or because you have a bad optical drive.

    If the firewire is known bootable on this machine, then you may have a bad firewire port, and bad firewire ports can make a machine take a really long time to boot. If this is what's going on, then it'll boot if you just wait.
     
  3. bfred123 thread starter macrumors newbie

    Joined:
    Jun 27, 2011
    #3
    OK -After doing some research, I tried booting in single user mode and running fsck -fy

    This returns several things which look suspicious:

    "Invalid leaf record count (It should be 27 instead of 26)"

    "Invalid sibling link (4, 24379)"

    Any suggestions?
     
  4. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #4
    Were there any I/O errors? Was it able to fix the issues? This could be related, or it may not be depending on the answer to these questions.
     
  5. bfred123 thread starter macrumors newbie

    Joined:
    Jun 27, 2011
    #5
    No, there were no I/O errors. I was able to install Mac OS on my firewire drive from another computer. Then I was able to boot the old MacBook from that. I ran Disk Utility on the internal drive and it told me it couldn't be repaired so erased and partitioned. So is there an easy way to get Mac OS back on the internal drive without a working optical drive? I am assuming that just copying the system folder from the firewire drive is a bad idea.
     
  6. ergun71 macrumors newbie

    Joined:
    Jun 25, 2011
    #6
    Maybe you could copy your OSX cd to your firewire disk and then boot from that one. After that you could try to install OSX on to your internal disk from there.
     
  7. ResPublica macrumors regular

    ResPublica

    Joined:
    Jun 12, 2011
    #7
    1. Install OS X on an external FireWire HD
    2. Run from that OS X installation the app "Carbon Copy Cloner"
    http://www.bombich.com/
    3. With this app, you can copy the OS X-installation from your FireWire HD to your internal HD.

    The fact that your OS X suddenly stopped working does make me think, however, that the internal hard drive has gone bad and needs to be replaced.
     
  8. bfred123 thread starter macrumors newbie

    Joined:
    Jun 27, 2011
    #8
    Update:

    Carbon Copy Cloner worked like a charm! The MacBook us up and running. Just to be safe I am going to order and install a new hard drive before I give this unit to my niece.

    The DVD drive is dead however and it's is not something I would try to replace myself. I guess an external optical drive is the best bet.

    If anyone has a recommendation where to buy these items, please let me know. I have heard that other world computing is good.

    Thanks for all your help!
     

Share This Page