Old Spaces mouse binding after upgrade

Discussion in 'Mac OS X Lion (10.7)' started by Krimoral, Mar 6, 2012.

  1. Krimoral macrumors newbie

    Joined:
    Mar 6, 2012
    #1
    Hello! First time poster, semi-long time reader here!

    So I FINALLY made the upgrade to Lion, and I'm having one small annoyance (I wouldn't really say problem as it's not effecting anything... yet).

    When I was using Snow Leopard, I set my Mouse4 and Mouse5 to Expose and Spaces. Now, Lion doesn't have spaces anymore like it used to, and seems to be using the Mission control like Expose was (at least thats how I think it seems to me..). Well after I've upgraded, I would have liked to have set the mouse up similarly, so I went to the Mission Control settings, and set the key bind to Mouse Button 5 (which was previously Mouse Button 4 in Snow Leopard for Spaces).
    The annoyance is, that next to the drop down box, it shows a little yellow triangle saying "This mouse button settings conflicts with the setting for another mouse button." When I had Snow Leopard, Mouse Button 5 was set for Expose, but now that that isn't in the system any more, it was removed... but the OS still thinks that the mouse button assigned to it is still assigned to "it."

    TL:DR version: An old keybinding for a removed feature is still key bound and I can't find out how to unset it (because the menu item for setting it was removed with the feature) so that it doesn't show an error when I try to set that button to something else.

    I have tried searching these forums, and I have tried using Google to the best of my good abilities. I've tried thinking of ways to maybe find a terminal command to unbind the mouse key, and even thought to look up if there is a keybinding file somewhere on the mac, but I haven't come up with anything useful. Any help would be appreciated, but not necessarily immediately as like I said, it's more of an annoyance (so far not messing anything up). I can still use the Mouse Button 5 for the key bind, and it works like it should ... it just displays that yellow error triangle and I'd like to fix it (and still use Mouse 5).

    Thanks in advance for any help!
    Krimoral
     
  2. garrettm30 macrumors newbie

    Joined:
    May 30, 2013
    #2
    I know this is an old post, but perhaps you are still looking for the answer. Anyway, I myself searched for hours on the Internet and never found the response, so I dug around and did some testing myself, and I'm posting this for the sake of others who may be looking for the answer.

    To delete that old keybinding, go to your the Preferences folder in your user Library (option-click the Go menu in the Finder to access it), and remove these two files:

    com.apple.symbolichotkeys.plist
    com.apple.symbolichotkeys.plist.lockfile (if present)

    You can just move them to the trash, then log out and back in. Afterward, you can go to the Mission Control preference pane to correctly set the mouse buttons as you desire without conflicts.

    Note that doing this will reset any other user-defined keyboard shortcuts.

    By the way, your mention of it being an old setting for Exposé getting stuck is what pointed me the right direction in my own investigation. Thanks. This has also solved a problem that I was experiencing with Mission Control occasionally forcing the desktop and Dashboard to restart.
     

Share This Page