Old user password no longer works after migration

Discussion in 'Mac Basics and Help' started by DelbertWilkins, Mar 25, 2012.

  1. DelbertWilkins macrumors newbie

    Joined:
    Mar 25, 2012
    #1
    During the week my macbook hard drive bit the dust. I had a new hard drive installed today and I migrated my old data over to the new drive from backup when I got it home. So far so good - except when I try to log-in to my migrated user, the password simply doesn't work. I've tried lots of alternatives, even though I'm 100% sure I know what the password is. It's simply inconceivable that it can be anything other than what I think it is!

    I tried resetting the password of the user account in question through another administrator user account, but even the new password doesn't work when I log out and try to log-in to my old user again. I've tried going in through the master password (honestly, I have no recollection of even setting a master password) but nothing that I type in works for that either. I only have a very limited pool of passwords and I've tried them all. It's not a caps lock problem or anything.

    I was running Lion on the account I'm trying to re-access from my old hard drive, but the new drive is running Snow Leopard. Could it be something to do with this? Failing that, is there any other way to reset the password?

    I'm absolutely at the end of my tether here and any advice would be much appreciated.
     
  2. Yixian macrumors 65816

    Joined:
    Jun 2, 2007
    Location:
    Europe
    #2
    Bump, I am having the same problem.

    I am surprised at how poor MR seems to be at providing answers to technical problems like this.
     
  3. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #3
    The forums are a great source of help, but on occasion a thread will get overlooked. A simple search would likely have reveal a number of threads providing solutions, however, so please don't complain about a lack of technical help. I myself have posted instructions for this several times.

    Boot from your Snow Leopard disk.
    Choose Utilities from the menubar, then Reset Password. (You'll have to choose the language at the first screen before the menubar appears.)
    Select the drive, then the user account having trouble, then enter a new password.
    Click the button at the bottom to Reset Home Directory Permissions and ACL's.
    Restart and try logging in again.

    If that doesn't work, I would create a new user account and move the files from that account into the new one. As the OP said, it may be because the account was used in Lion, with FileVault 2 (considering there was a master password set, I'm assuming FileVault was in use), which is handled very differently in Snow Leopard.

    jW
     
  4. Yixian macrumors 65816

    Joined:
    Jun 2, 2007
    Location:
    Europe
    #4
    This is a MacBook Air, I don't have an external optical drive or a Snow Leopard disk, but apparently I can get to that screen by holding command R on startup. I'll try this.

    For the record I have noticed this mentioned a few times on MR with no replies!
     
  5. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #5
    Try this hint i saw on another forum. It will work in PPC Macs and Intel Macs.

    Then it will startup like new asking to create a initial Admin user. Use this to create another account and then you can delete the first account that isn't working once you are in OS X.
     

Share This Page