Older Mac Needs Updated Java

Discussion in 'Mac Basics and Help' started by EJ2014, Jan 18, 2014.

  1. EJ2014 macrumors newbie

    Joined:
    Jan 18, 2014
    #1
    I signed up for an online class that requires Java Update 16 (1.6.0_51 for Fall 2013), however, I have an older Mac (Version 10.5.8) and I cannot seem to get the proper version of Java to download. Any thoughts or ideas? Thanks!!
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    Java Update 16 is for Mac OS X 10.6 (Snow Leopard)(SL)
    You will need to upgrade to Snow Leopard to get that Java SE 6.
    Very easy to purchase Snow Leopard direct from Apple.
    http://store.apple.com/us/product/MC573Z/A/mac-os-x-106-snow-leopard
    Less than $20
    And, you can see that you will need to have an intel processor to do that upgrade to 10.6

    I suspect that (still running 10.5.8) you have a PowerPC, such as a G4, or a G5.
    Which Mac model do you have?
     
  3. And macrumors 6502

    And

    Joined:
    Feb 23, 2009
    Location:
    92 ft above sea level, UK
    #3
    Just to finish the point being made here, snow leopard cannot be installed on a G4 or G5. You would need to either buy/borrow another machine to undertake the course.
     
  4. wordsworth macrumors regular

    Joined:
    Apr 7, 2011
    Location:
    UK
    #4
    It may well be that the OP can indeed install Snow Leopard. I recently installed SL on a Core2Duo iMac (an Intel Mac rather than PowerPC) running 10.4.

    To the OP: What Mac do you use? If you're not sure whether it's PowerPC or Intel, click on the Apple icon in the menu bar at top of the screen. It'll show you what sort of processor your computer uses: PowerPC or Intel. If it's the latter, you can install Snow Leopard on it.
     

Share This Page