Older version of xcode

Discussion in 'iOS Programming' started by rich1812, Nov 7, 2018.

  1. rich1812, Nov 7, 2018
    Last edited: Nov 7, 2018

    rich1812 macrumors member

    Joined:
    Oct 4, 2015
    Location:
    earth
    #1
    Hello, I have xCode 10.1 on my Mac. I downloaded an older xcode project, which was written in Swift 2, it won't open in xcode 10.1. So I downloaded xcode 8.3.xip to try to convert it to Swift 3. But the xcode 8.3 won't open. Does xcode 8.3 co-exist with xcode 10.1? Does xcode 8.3 run on Majove at all? What can I do? Thanks.
     
  2. PhoneyDeveloper macrumors 68040

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    Does 10.1 refuse to open it completely or it just gives errors? If you can set the swift version to 4.2 and let it build it will show errors but it should help you upgrade them to the current swift version.

    Otherwise you could make a new project and copy over the source files and storyboards and fix the errors. If the project isn't too big there shouldn't be that much code to update.
     
  3. rich1812 thread starter macrumors member

    Joined:
    Oct 4, 2015
    Location:
    earth
    #3
    Hi,

    The precise words Xcode 10.1 gave me are:
    Unsupported Swift Version
    The targets “Adafruit Bluefruit LE Connect” and “Adafruit Bluefruit LE Connect WatchKit Extension” contains source code developed with Swift 2.x. This version of Xcode does not support building or migrating Swift 2.x targets.

    I am afraid I don't know Swift 3 well enough to create a new project. I am still learning. :(
     
  4. PhoneyDeveloper macrumors 68040

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
  5. rich1812 thread starter macrumors member

    Joined:
    Oct 4, 2015
    Location:
    earth
    #5
    Thank you very much. I didn't realize this version exist! :)
     

Share This Page