OMG please help with redsnow :(:(

Discussion in 'Jailbreaks and iOS Hacks' started by apachehavok, Feb 22, 2012.

  1. apachehavok macrumors member

    Joined:
    Nov 8, 2011
    #1
    hey everyone

    Have an iphone 4 from the US in need of jailbreaking and unlocking.

    I had ios 4.3 something. I followed the instructions to a T!!!!! On how to update to 5.0.1 WITHOUT updating the baseband.

    Created the custom ISPW no BB and restored to that one through itunes DFI mode. Then went ahead and jailbroke with latest redsnow.

    And the baseband was updated??? WTF???? Tried using ultra snow with different sim and says invalid sim :( :(

    What happened???????
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Ultrasnow only unlocks baseband 01.59.00 on the iphone 4.
    That's the baseband that came with firmware 4.0 and 4.0.1
    Since your phone was already on 4.3 then you were out of luck and couldnt use ultrasnow to begin with.
    If you did the updating to custom 5.0.1 like you said you should still be able to unlock it using a gevey turbo sim.
    Let us know the modem firmware your phone is on right now.
     
  3. apachehavok thread starter macrumors member

    Joined:
    Nov 8, 2011
    #3
    gotcha thanks for replying.

    The iphone baseband is at 04.10.01

    This is the GF's phone and im pretty sure it shipped with 4.3.

    So if that was the case then it was screwed to begin with?
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Yes, but you're still good since you saved the baseband from 4.3 firmware.
    If you updated to factory 5.0.1 you wouldnt be able to use gevey either and nothing could unlock it.
    You can unlock it the way it is now by purchasing a gevey.
    Then install furious mod from cydia and you're set.
     
  5. apachehavok thread starter macrumors member

    Joined:
    Nov 8, 2011
    #5
    gotcha thanks soooo much for the info makes me feel better.

    Now my phone is at 01.59.00

    So, if I just make the custom BB in redsnow, then restore to that BB FW I made from itunes, then restore my backup from itunes to get my apps back then use redsnow again to run a regular jailbreak I should be good to go?

    Are those the correct steps to get it working with ultrasnow on mine? (I just tested my phone with ultra snow (on FW 4.0.1) and it works with other sims just fine. But I want to update to the latest FW and still use ultrasnow

    Is that the best way to do it?

    Thanks for all your help!!
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Yes, create a custom 5.0.1 no_bb ipsw with redsnow.
    Put your iphone in pwned dfu using redsnow.
    Open itunes and select the custom 5.0.1 you made with redsnow.
    Then restore to that.
    You will be on 5.0.1 with your baseband untouched still on 01.59.00
    Then JB again if you want and restore your backup and your apps etc...
    Good luck.
    A.J.
     
  7. apachehavok thread starter macrumors member

    Joined:
    Nov 8, 2011
    #7
    Hey AJ thanks man I really appreciate it!!

    2 more questions and ill be out of your hair and pronounce you as iphone knowledge awesome dude #1 :)

    So after I restore to the custom BB base band preserved file, running ultra snow like normal wont revert any changes correct?

    AND

    There is an unteathered solution for the 4S to jailbreak (no unlock) out now right? The GF loved the 5 icon docks and SB settings and it looks like shes going to get a new phone haha

    You da man!
     
  8. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #8
    You might lose some of your JB apps, not all 4+ JB apps are compatible with 5.01

    Restoring your itunes backup is ok, but start from scratch with your JB apps.


    Better be quick with the new 4S before they are shipped with the soon to drop 5.1, that iOS can't be jailbroken (Yet)
     
  9. apachehavok thread starter macrumors member

    Joined:
    Nov 8, 2011
    #9
    Hmmmm. Well it makes me wonder weather or not its worth it then.

    Like its working great the way I like it but some newer apps like GTA 3 require 4.3 hmmm
     
  10. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #10
    It's definately worth it, most apps that don't work on 5+ have other similar apps that do work! Sometimes you have to figure out what replaces what, but all in all a far better phone on 5+ than it was on 4+
     
  11. apachehavok thread starter macrumors member

    Joined:
    Nov 8, 2011
    #11
    Gotcha so am I correct in saying that the same process or unlock the new 4S is the same as the 4 with the latest ultrasnow?

    Also, if im on the super old baseband and I want to keep that, restoring to the custom basband preserved, then running ultrasnow normally wont mess anything up right? Like if I follow the steps I outlined above exactly?

    i guess my only concern/question is after I have the custom BB preserved installed on the phone, running redsnow to jailbreak it wont undo the baseband correct?

    Thanks all!!
     

Share This Page