on iphone it says I have new emails but they are not there?

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by UKmacman, Jul 5, 2010.

  1. UKmacman macrumors regular

    Joined:
    Oct 4, 2007
    #1
    I have set up my mobileme on my iphone (and ipad). On the iphone 4 it keeps saying I have new emails but when I click through they are not always there. Anyone got any idea why this might be?

    They are on me.com and also go to my ipad ok - just an issue with the iphone 4.
     
  2. Lokrado macrumors regular

    Joined:
    Jan 26, 2009
    Location:
    Denmark
    #2
    happens to me all the time.
    its when you check the mail on another device, for some reason the iphone doesn't mark it as read before you enter mobilemail.app and resync
     
  3. UKmacman thread starter macrumors regular

    Joined:
    Oct 4, 2007
    #3
    It seems to do this even if I have not looked at the emails on another advice. Anyone have any idea how to fix this?

    just spoke to a mobileme rep and they said turn off mail and on again and it worked!
     
  4. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #4
    I believe this is new for iOS 4. Seems that when I delete email from the Inbox it takes a little time for the badge to update. This did not happen before upgrading to iOS 4. If I just ignore it, it will update on it's own in a little while.
     
  5. UTVOL06 macrumors member

    UTVOL06

    Joined:
    Jun 15, 2010
    Location:
    South East, USA
    #5
    Same issue. With the mail app in the background. I get a new email notification. I check the inbox. It's not there. I close out the mail app with the x button. Reopen the mail app and the email is there to read. I suppose if I left the mail there is would update as mentioned above, but this is pathetic when the multitasking function is in use and it won't even show up when clicked on. :mad:

    Hopefully will be fixed in the next update.
     
  6. summerpeach macrumors member

    summerpeach

    Joined:
    Jun 15, 2010
    #6
    this is really really annoying. it keeps happening even when i exit out of mail several times.
     
  7. ri0ku macrumors 6502a

    Joined:
    Mar 11, 2009
    #7
    This has been happening on my ipad since Mobileme was updated.. very frustrating... I used to be able to look at new mail on my macbook pro and once I had viewed it on all my other devices it would be "read" so I wouldt get the little number badge on my ipad.

    Now even when I have read an email on the MBP the badge still remains on the ipad stating I have a new mail when infact it WAS a new mail until I had read it on the MBP.

    Hope this gets sorted.
     
  8. garethjs macrumors 6502

    Joined:
    Nov 11, 2008
    #8
    Nope. This has always been the case. The badge is pushed and pulled on the Mac. On the iDevices, it's set to only push. Receive an email. Badge appears on all devices. Read it on your iPad. Status is pushed to Mac and badge clears. But on your iPhone badge is still showing until you open the app and then it checks to see what's been read or not and clears it automatically. It's been like that since 2.0. If you receive a second email, then the new badge count is pushed to all the devices. Its to save battery but I can't imagine it saving that much.

    http://support.apple.com/kb/TS1795

    With 4.0 I'm not sure if it's a threaded email bug or a multi-tasking bug but at times when I get mail. I get the alert and the badge but when I open the app it's not there. Solution, db click home button, close the mail app that is running in the shortcut bar, open mail app again and your new mail appears.
     
  9. lupodesmo macrumors newbie

    Joined:
    Jul 24, 2010
    #9
    iphone issues with mobile me

    I have the same problem since updating the 3GS to iOS 4.0.....
    Even closing the mailapp several times and opening again does not work.
    The mails can be read on the desktop.
    Or writing a mail on the desktop , saving as a draft. Then reopening the draft,
    only the adress and header appears, the message itself is lost, but the
    whole draft is synced to the iphone ??!!!
    Any help?
     

Share This Page