"On My iPad" Calendar?!

Discussion in 'iPad Tips, Help and Troubleshooting' started by toonzes, Dec 3, 2010.

  1. toonzes macrumors newbie

    Joined:
    Nov 14, 2007
    #1
    Has anyone else noticed that upgrading to iOS 4.2 added an "On My iPad" calendar to their calendar list? This didn't happen when I upgraded my iPhone and, frankly, I don't want it there, because I want all my calendars synced through MobileMe.

    Does anyone know if there's a way to get rid of this calendar? I know I can simply ignore it, but I don't want to accidentally make an entry on this calendar that will then fail to sync to MobileMe. So I'd prefer simply to get rid of it. As I said, there's no equivalent on my iPhone, and I like it that way.

    Thanks for your help.
     
  2. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #2
    I'm pretty sure that "on my iPad" calendar does get synced to MobileMe, and I imagine if you don't want it, you can delete it from MobileMe.
     
  3. toonzes thread starter macrumors newbie

    Joined:
    Nov 14, 2007
    #3
    Don't Think So...

    That doesn't appear to be the case. I just tried a test entry, and it didn't sync. In fact, the "On My iPad" calendar doesn't show up in MobileMe at all. Also, it would seem a bit odd for a calendar outside of the ones listed under "MobileMe" to sync with MobileMe nonetheless.

    I should also mention that I do not have my iPad set to sync with my Mac over iTunes. I'm syncing strictly over the air. But I still can't seem to find a way to delete the unwanted "On My iPad" calendar.
     
  4. b.c. macrumors 6502

    Joined:
    Nov 5, 2008
    #4
    if you're using MobileMe sync, are you set up to use the new version of Mobile Me calendar? (how to check: here)

    I'm using MobileMe sync with the new version of calendar, and iPad w/ OS 4.2 and don't see an "On My iPad" calendar. Like you, I'm also syncing MM only over the air. but I seem to recall seeing that "On My iPad" calendar before... probably before I had sync set up properly.

    if you're were using the new MM calendar under OS 3.2, you had to manually setup a separate calDAV account entry in order to sync your new MM calendars. With OS 4.2 you need to remove that separate entry and simply enable calendar sync in your main MM account.

    just wondering if you've got something going on there and need to check your setup?
     
  5. toonzes thread starter macrumors newbie

    Joined:
    Nov 14, 2007
    #5
    Thanks - Fixed It

    So, I went through and deleted my MobileMe account and all my calendars from my iPad (although the "On My iPad" calendar stubbornly remained).

    I then added back my MobileMe account, including calendars, at which point I was asked whether I wanted to merge my existing ("On My iPad") calendar with my MobileMe calendars, to which I replied "Yes." Once that calendar was reorganized under my MobileMe calendars, I simply logged on to me.com and deleted that calendar from the list. That did the trick.

    Thanks again for your help.
     
  6. b.c. macrumors 6502

    Joined:
    Nov 5, 2008
    #6
    you're welcome. glad you got it sorted out
     
  7. Pale Rider macrumors newbie

    Joined:
    Sep 17, 2002
    #7
    Easily Fixed

    This was bugging me, too. It seemed that the Calendar On My iPad appeared out of nowhere. Anyway, this worked for me; YMMV:

    1. On my iPad, open Settings
    2. Scroll to Mail, Contacts & Calendars
    3. Click on the MobileMe Account that is set to sync for Calendars [I have a few MM accounts, but only one syncs calendars]
    4. Click the slider to turn off the Calendars
    5. Click the Delete all data option.
    6. Close Settings & open Calendar, confirm the MM calendars are gone
    7. Go back to Settings, and re-enable calendar sync; I was not asked if I wanted to replace or merge any local data
    8. For me, the local On My iPad calendar was gone, everything else was there that I wanted.

    Note: previous poster toonzes may have meant exactly what I described, when he/she said to "delete the account." Note that I did not delete the account, just briefly turned off calendar syncing.
     
  8. blow45 macrumors 68000

    Joined:
    Jan 18, 2011
    #8
    That's what we are all doing and its not working... What a bummer that I have to open the Mac and go to mm to solve this... Anyway...hope I do at least solve it..
     

Share This Page